summaryrefslogtreecommitdiff
path: root/net-misc/mcproxy/mcproxy-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /net-misc/mcproxy/mcproxy-1.1.1.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'net-misc/mcproxy/mcproxy-1.1.1.ebuild')
-rw-r--r--net-misc/mcproxy/mcproxy-1.1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/mcproxy/mcproxy-1.1.1.ebuild b/net-misc/mcproxy/mcproxy-1.1.1.ebuild
new file mode 100644
index 000000000000..463944737b3b
--- /dev/null
+++ b/net-misc/mcproxy/mcproxy-1.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info qmake-utils systemd
+
+DESCRIPTION="A multicast proxy for IGMP/MLD"
+HOMEPAGE="https://mcproxy.realmv6.org/ https://github.com/mcproxy/mcproxy"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-qt/qtcore:5
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${P}/${PN}"
+
+PATCHES=( "${FILESDIR}/fix_checksum_calculation.patch" )
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_prepare() {
+ # Change install path from '/usr/local/bin' to '/usr/bin'
+ sed -e 's/local//' -i mcproxy.pro || die
+
+ default
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_compile() {
+ default
+
+ use doc && emake doc
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED%/}" install
+
+ insinto /etc
+ doins mcproxy.conf
+
+ newinitd "${FILESDIR}"/mcproxy.initd mcproxy
+ systemd_dounit "${FILESDIR}"/mcproxy.service
+
+ newconfd "${FILESDIR}"/mcproxy.confd mcproxy
+
+ use doc && dodoc -r ../docs/.
+}