summaryrefslogtreecommitdiff
path: root/net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild')
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild
new file mode 100644
index 000000000000..bfe0d0720d9c
--- /dev/null
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.19-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic autotools linux-info
+
+DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
+HOMEPAGE="http://lksctp.sourceforge.net/"
+SRC_URI="https://github.com/sctp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="static-libs"
+
+# This is only supposed to work with Linux to begin with.
+DEPEND=">=sys-kernel/linux-headers-2.6"
+RDEPEND=""
+
+REQUIRED_USE="kernel_linux"
+
+CONFIG_CHECK="~IP_SCTP"
+WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README ROADMAP )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc doc/*txt
+ newdoc src/withsctp/README README.withsctp
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}