summaryrefslogtreecommitdiff
path: root/net-misc/liveice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
commita4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (patch)
tree1c6cf78322fbf3379d5b7e4f4b836a42c5fddd19 /net-misc/liveice
parenta4e37a9aeeef82eba5858dbc609f65b838b0f836 (diff)
gentoo auto-resync : 06:10:2022 - 01:20:42
Diffstat (limited to 'net-misc/liveice')
-rw-r--r--net-misc/liveice/Manifest3
-rw-r--r--net-misc/liveice/files/liveice-2000530-clang16.patch37
-rw-r--r--net-misc/liveice/liveice-2000530-r3.ebuild (renamed from net-misc/liveice/liveice-2000530-r2.ebuild)24
3 files changed, 55 insertions, 9 deletions
diff --git a/net-misc/liveice/Manifest b/net-misc/liveice/Manifest
index a6309066ffda..01cde9dda6e9 100644
--- a/net-misc/liveice/Manifest
+++ b/net-misc/liveice/Manifest
@@ -1,4 +1,5 @@
AUX liveice-2000530-build.patch 990 BLAKE2B a1406d01255445b87a10e6bbd89aaf94a94539315304209ec18fdff88c62288323f2f5b5306e42671d02ed13d0d74d28f883a06bddea921572404775d38060f6 SHA512 8004c5d99aebb76b70158abdbc95550d858d74790882be531c7472a349dec104fe7f54a38f616106004385412bda159b01426a0a71606e9c7b1b3e58bcd9cef1
+AUX liveice-2000530-clang16.patch 880 BLAKE2B 68218724d40b81e032811949d28937f1c81849783ac7601200bb99a55afb56dfc5e8177b59527730361514d95ab4b2235d5a6f5fe0b892c2ab36894cec7cc465 SHA512 aa011d32bde8733f43601e5f0208766aa3105379083c595986e9bda72097a7097d4adaa832e84b713335da1fbaab10b1036e0f7d415b24ce5f26cda56244af06
DIST liveice-2000530.tar.gz 85171 BLAKE2B c804a4f64432cba3181e633b9edb4e67f39c18805290bfae290ae78bcb80d865a3106af8cfab40e214a043609d837bc887d0eb50adbaad3f1d2838dd44e4de58 SHA512 6b6b7ed7f4aa2b27e2b97db407554955e332002c059bbf3fbb5c5fe60c1d6aa5cd594d2698524a9b447fc3a81de96fb46945c2386467f1773ff0ba2b10da78e4
-EBUILD liveice-2000530-r2.ebuild 710 BLAKE2B 87c8a40be04e4f33745fd20cbd41b91196df7ef20ef33a9ff237a8ca387f8588cfd651af4f001117d004b3607f8c590b6acc230ccea71458451282bd5c0301b1 SHA512 4d4c34d96d1ff30a4d246c9b39266a0b704df8c452c16f60cb6ae5fb315f03249aae9ba89bb49db290ff99ba2152f5ff8d67f1543a52af6452bc2925145c81d5
+EBUILD liveice-2000530-r3.ebuild 926 BLAKE2B 6570a32aeacab2da4becf2feb7d7f87c621924bd9c2266b81f61530e66a66a9d2605c9041be5d8c9c029250b307a45256d840e0df6e07ba1fa0f79c42b1b2d63 SHA512 f65a0101831888d0362367d2a312d5798638a6ca422fbd25fd5cf036aef39ae65bd90dd3f8f2153bf26fecb5e8b50693f3f457372d945d0f4af3c3d685aab9fa
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/liveice/files/liveice-2000530-clang16.patch b/net-misc/liveice/files/liveice-2000530-clang16.patch
new file mode 100644
index 000000000000..6d1964a9c097
--- /dev/null
+++ b/net-misc/liveice/files/liveice-2000530-clang16.patch
@@ -0,0 +1,37 @@
+Also issues with implicit basename(3), but that is handled from the ebuild.
+https://bugs.gentoo.org/861644
+https://bugs.gentoo.org/870838
+--- a/mixer.c
++++ b/mixer.c
+@@ -29,4 +29,5 @@
+ #include "audio_proc.h"
+ #include "controls.h"
++#include "url.h"
+
+
+@@ -40,4 +41,5 @@
+ #include <time.h>
+
++int parse_file_metadata(char *filename,char **title,char **artist,char **album,char **url);
+
+ short audio_buffer[BUF_SIZE];
+--- a/mixer.h
++++ b/mixer.h
+@@ -157,2 +157,3 @@
+ void write_logfile(cptr ch);
+ void execute_update_script(cptr ch);
++void shout_streamer(void);
+--- a/streams.c
++++ b/streams.c
+@@ -32,4 +32,5 @@
+ #include "serverlib.h"
+ #include "audio_proc.h"
++#include "mixer.h"
+
+ #ifdef SOUNDCARD_SUPPORT
+--- a/url.h
++++ b/url.h
+@@ -11,2 +11,3 @@
+ int string_contains(char *string,char *seek);
+ void strtoupper(char *string);
++char *url_encode(char *str, char **result_p);
diff --git a/net-misc/liveice/liveice-2000530-r2.ebuild b/net-misc/liveice/liveice-2000530-r3.ebuild
index cc73e827d6ac..d00733459f71 100644
--- a/net-misc/liveice/liveice-2000530-r2.ebuild
+++ b/net-misc/liveice/liveice-2000530-r3.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Live Source Client For IceCast"
-HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2+"
SLOT="0"
@@ -15,21 +16,28 @@ KEYWORDS="~amd64 x86"
RDEPEND="
media-sound/lame
- media-sound/mpg123"
+ media-sound/mpg123
+ sys-libs/ncurses:="
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}"
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
src_prepare() {
default
+
eautoreconf
- tc-export CC
}
src_configure() {
+ tc-export CC
append-flags -fcommon
- default
+
+ # seems to expect GNU's basename, but use simple builtin my_basename
+ # rather than assume by forcing either -D_GNU_SOURCE or <libgen.h>
+ econf ac_cv_func_basename=no #870838
}
src_install() {