summaryrefslogtreecommitdiff
path: root/net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild')
-rw-r--r--net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild b/net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild
new file mode 100644
index 000000000000..296ae54cd94a
--- /dev/null
+++ b/net-misc/lambdamoo/lambdamoo-1.8.1-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="networked mud that can be used for different types of collaborative software"
+HOMEPAGE="https://sourceforge.net/projects/lambdamoo/"
+SRC_URI="mirror://sourceforge/lambdamoo/LambdaMOO-${PV}.tar.gz"
+
+LICENSE="LambdaMOO GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND="sys-devel/bison"
+RDEPEND=""
+
+S=${WORKDIR}/MOO-${PV}
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${PV}-enable-outbound.patch
+ sed -i Makefile.in \
+ -e '/ -o /s|$(CFLAGS)|& $(LDFLAGS)|g' \
+ || die "sed Makefile.in"
+ eautoreconf
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS} \
+ -DHAVE_MKFIFO=1"
+}
+
+src_install() {
+ dosbin moo
+ insinto /usr/share/${PN}
+ doins Minimal.db
+ dodoc *.txt README*
+
+ newinitd "${FILESDIR}"/lambdamoo.rc ${PN}
+ newconfd "${FILESDIR}"/lambdamoo.conf ${PN}
+}