summaryrefslogtreecommitdiff
path: root/net-misc/l7-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-misc/l7-protocols
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-misc/l7-protocols')
-rw-r--r--net-misc/l7-protocols/Manifest4
-rw-r--r--net-misc/l7-protocols/l7-protocols-2009.05.28-r1.ebuild (renamed from net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild)44
-rw-r--r--net-misc/l7-protocols/metadata.xml6
3 files changed, 28 insertions, 26 deletions
diff --git a/net-misc/l7-protocols/Manifest b/net-misc/l7-protocols/Manifest
index a09d78ce877b..2db91be5604a 100644
--- a/net-misc/l7-protocols/Manifest
+++ b/net-misc/l7-protocols/Manifest
@@ -1,3 +1,3 @@
DIST l7-protocols-2009-05-28.tar.gz 142050 BLAKE2B b70a0c7267bc462fc193cb05ea16849ea064b39d358d1073884ca718b92a39b72e78d5f8cec600a8acdba48bda72dbc07f20bbee76b5f7670d09dee93e164ffc SHA512 020730d0170537213080dcefd847439a2306eea759317e4054549d12e344520e9db222ca48f74c184cb17ba5ff244270b688fb7e89ed0dd21a196e02721e4477
-EBUILD l7-protocols-2009.05.28.ebuild 1603 BLAKE2B 0be523fa3efbf5035df721038030218b42d2608a508fbc86e295fc68d421b1c33a718cd368434c5ac36fe3616f6acc47661cece3a46ec99fc7097a2cf3e13b52 SHA512 2ad02d5291c8e2f843a71e70f4cc9357ec78174d4c901b73caf068020e8256df9e3aa355d5349615f93d89e29a062ff8ad8471963ca02e57e52cca2ebe92e332
-MISC metadata.xml 675 BLAKE2B c507f9e684082db2d90b1e811da4a8408e6d3571b217431c33f7f1c20af5a00901c5094d2d35935e14b40ba0cf700bc070ba4df57c0de4e35633ee04ece36186 SHA512 de1be10711122953af535fc50b2a15a32fbed1daf550b2b50bea0be912167a01ea2e3d1ae4a6d591ee7697e1b0c1738d5c76fbfd76f4620e03c0f271bde487d6
+EBUILD l7-protocols-2009.05.28-r1.ebuild 1737 BLAKE2B 3373e258d8373ad0fa367098ecb618904de04cbad5cfa50798078b32a6e45d07a7afd69046f04dbedd6f8a787a610d82c7c3025d9068199088b6459c63036c0f SHA512 929a4bda7b93e178a8ae9ac44fd4a6e6fc4154067eebe88aa50e0b41594f6d950b53496d397f30d02e25ac69656b154865fd57999d8a3c1e5354ed5102680f58
+MISC metadata.xml 641 BLAKE2B 9413688e3c6c77f48d5a3787318c03bc6769d9838a47ecce6241d950da843a0181fc963273ff4b54dfa5325c271dbac4d7d4d6f617467c2fd28baf878a706115 SHA512 c2af3723eac88c6e4fbe5dd6920ad6ed2ad2b1339965edbae5cad669b9470a0818520041b5335868fe52a9b57856f53e7088e91fd0403f73c087fea2e8c61eeb
diff --git a/net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild b/net-misc/l7-protocols/l7-protocols-2009.05.28-r1.ebuild
index c6dc39ec2398..a6f18a630b65 100644
--- a/net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild
+++ b/net-misc/l7-protocols/l7-protocols-2009.05.28-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils fixheadtails toolchain-funcs
@@ -10,27 +10,28 @@ IUSE=""
MY_P=${PN}-${PV//./-}
DESCRIPTION="Protocol definitions of l7-filter kernel modules"
-HOMEPAGE="http://l7-filter.sourceforge.net/protocols"
+HOMEPAGE="http://l7-filter.sourceforge.net/protocols
+ https://l7-filter.clearos.com/docs/start"
SRC_URI="mirror://sourceforge/l7-filter/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="~amd64 ~arm ~x86"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- sed -e "s|gcc.*\-o|$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o|g" \
- -e "s|g++.*\-o|$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o|g" \
- -i testing/Makefile
+src_prepare() {
+ sed -e "s|gcc.*\-o|$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o|" \
+ -e "s|g++.*\-o|$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o|" \
+ -i testing/Makefile || die
+ sed -e "s|f in data|f in ${EPREFIX}/usr/share/l7-protocols/data|" \
+ testing/timeit.sh || die
ht_fix_file testing/*.sh
+ eapply_user
}
src_compile() {
- emake -C testing || die
+ emake -C testing
}
# NOTE Testing mechanism is currently broken:
@@ -46,20 +47,21 @@ src_compile() {
#}
src_install() {
- dodir /usr/share/${PN}
- pushd testing > /dev/null
+ dodir /usr/{share,lib}/${PN}
+ mv testing/data example_traffic "${ED}"/usr/share/${PN} || die
+
+ pushd testing >/dev/null || die
cp -pPR randprintable randchars test_speed-{kernel,userspace} README \
- match_kernel *.sh data "${D}"/usr/share/${PN}
- popd > /dev/null
- mv example_traffic "${D}"/usr/share/${PN}
+ match_kernel *.sh "${ED}"/usr/lib/${PN} || die
+ popd >/dev/null || die
- dodoc README CHANGELOG HOWTO WANTED || die
+ dodoc README CHANGELOG HOWTO WANTED
for dir in extra file_types malware ; do
newdoc ${dir}/README README.${dir}
done
- rm -rf README CHANGELOG HOWTO LICENSE Makefile WANTED */README testing
+ rm -rf README CHANGELOG HOWTO LICENSE Makefile WANTED */README testing || die
dodir /etc/l7-protocols
- cp -R * "${D}"/etc/l7-protocols
- chown -R root:0 "${D}"
+ cp -R * "${ED}"/etc/l7-protocols || die
+ chown -R root:0 "${ED}" || die
}
diff --git a/net-misc/l7-protocols/metadata.xml b/net-misc/l7-protocols/metadata.xml
index 30de8b041c0b..4f319e6eb958 100644
--- a/net-misc/l7-protocols/metadata.xml
+++ b/net-misc/l7-protocols/metadata.xml
@@ -7,9 +7,9 @@
</maintainer>
<longdescription>
These are patterns (protocol definitions) for the Linux layer 7 packet
- classifier (l7-filter). To use them, you need the kernel and iptables patches
- (or l7-filter userspace version) available trough ebuild tree as
- net-misc/l7-filter and net-firewall/iptables built with l7filter USE flag.
+ classifier (l7-filter). To use them, you need the l7-filter userspace version
+ available trough ebuild tree as net-misc/l7-filter and net-firewall/iptables
+ built with netlink USE flag.
</longdescription>
<upstream>
<remote-id type="sourceforge">l7-filter</remote-id>