summaryrefslogtreecommitdiff
path: root/net-misc/iperf/iperf-3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /net-misc/iperf/iperf-3.7.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'net-misc/iperf/iperf-3.7.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-3.7.ebuild b/net-misc/iperf/iperf-3.7.ebuild
new file mode 100644
index 000000000000..9b5ce32eaae2
--- /dev/null
+++ b/net-misc/iperf/iperf-3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="${HOMEPAGE}archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint"
+IUSE="libressl profiling sctp static-libs"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sctp? ( net-misc/lksctp-tools )
+"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P/_/}
+
+src_configure() {
+ use sctp || export ac_cv_header_netinet_sctp_h=no
+ econf \
+ $(use_enable profiling) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ prune_libtool_files
+}