summaryrefslogtreecommitdiff
path: root/net-misc/iperf/iperf-3.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /net-misc/iperf/iperf-3.10.1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'net-misc/iperf/iperf-3.10.1.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.10.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-3.10.1.ebuild b/net-misc/iperf/iperf-3.10.1.ebuild
new file mode 100644
index 000000000000..9e9f34b2843b
--- /dev/null
+++ b/net-misc/iperf/iperf-3.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf"
+SRC_URI="https://github.com/esnet/iperf/archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_/}"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="sctp"
+
+DEPEND="
+ dev-libs/openssl:0=
+ sctp? ( net-misc/lksctp-tools )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md RELNOTES.md )
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with sctp)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ systemd_dounit contrib/iperf3.service
+
+ find "${ED}" -name '*.la' -delete || die
+}