summaryrefslogtreecommitdiff
path: root/net-misc/iperf/iperf-2.99999.99999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /net-misc/iperf/iperf-2.99999.99999.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'net-misc/iperf/iperf-2.99999.99999.ebuild')
-rw-r--r--net-misc/iperf/iperf-2.99999.99999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-2.99999.99999.ebuild b/net-misc/iperf/iperf-2.99999.99999.ebuild
new file mode 100644
index 000000000000..ee2ce2958181
--- /dev/null
+++ b/net-misc/iperf/iperf-2.99999.99999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3
+
+DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
+HOMEPAGE="http://iperf2.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.gz"
+EGIT_REPO_URI="https://git.code.sf.net/p/iperf2/code"
+
+LICENSE="HPND"
+SLOT="2"
+KEYWORDS=""
+IUSE="ipv6 threads debug"
+
+DOCS="INSTALL README"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.12-ipv6.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug debuginfo) \
+ $(use_enable ipv6) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}