summaryrefslogtreecommitdiff
path: root/net-misc/httpstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /net-misc/httpstat
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'net-misc/httpstat')
-rw-r--r--net-misc/httpstat/Manifest4
-rw-r--r--net-misc/httpstat/httpstat-1.3.1-r1.ebuild28
-rw-r--r--net-misc/httpstat/httpstat-1.3.1.ebuild2
3 files changed, 32 insertions, 2 deletions
diff --git a/net-misc/httpstat/Manifest b/net-misc/httpstat/Manifest
index 4f8ad87f7600..608084dc54df 100644
--- a/net-misc/httpstat/Manifest
+++ b/net-misc/httpstat/Manifest
@@ -1,4 +1,6 @@
AUX httpstat-1.2.1-gentoo-tests.patch 840 BLAKE2B 478fc8c29c816be383def1d2f2194fe7d0fb888487c45afeba9b3a7808bbc01cbf1c836ee14b5f57115e19a1f63537736d137e19b3e1eac9b8af65f3519d5142 SHA512 6e904552c42e8d5cc9f6b298902601cb7ce1304ba2c85f0910f508ac09e5257562e7ed94fb0462512f02caff2a83fa2bb6ec35045a720e25c4f91e976cd1c99b
+DIST httpstat-1.3.1.gh.tar.gz 97691 BLAKE2B f7a5388c3891c1caac654c6c9be425864e2a037eba2e12229ec72c847864f7be23b64d5450ebb42f976335f5b6ca878f1ee555ee3b2178c1a10c5969f883604d SHA512 bca91afe14d50af37c741ca4baa7d3843b010bb6dc012c72bd28c43f59099c20628cadc4dd80652dffeb1d26fb07f5cf156a3f6bf9eba1f6e121d4b250020b46
DIST httpstat-1.3.1.tar.gz 97691 BLAKE2B f7a5388c3891c1caac654c6c9be425864e2a037eba2e12229ec72c847864f7be23b64d5450ebb42f976335f5b6ca878f1ee555ee3b2178c1a10c5969f883604d SHA512 bca91afe14d50af37c741ca4baa7d3843b010bb6dc012c72bd28c43f59099c20628cadc4dd80652dffeb1d26fb07f5cf156a3f6bf9eba1f6e121d4b250020b46
-EBUILD httpstat-1.3.1.ebuild 650 BLAKE2B dff7a361afc34a88850fbebbc196db223250025ce94f56afe647b30a02185481cef8355eec8049fbce9954da125da02ea9c4a8ab40a688ab29b0e54ba3eb172f SHA512 f2cab75573ad3883310ff6d5223df7674a2413216d6a6fee8fc40d9d1bd99eb2f3cfecba09da67624fbb0d610aa98472043493395a95060e2b188829ecd16a09
+EBUILD httpstat-1.3.1-r1.ebuild 687 BLAKE2B 2666f7cbc751f475732fd608e427994bdccf94f29b020451224685fab32bac4063c5ee46ace7b45936f68a40f6fd68dc5d64a966fad50a78a24409098a1065f0 SHA512 c007488b482133402b22df9b7590d84bb92fcd1c4daefcff126e8c3d78e6222c99fb80b818981f3b7dffe0bde369ba7c783c6f1f3233943d62aeb7b2a27f1f56
+EBUILD httpstat-1.3.1.ebuild 650 BLAKE2B 3544466383b4f602a0dcc269b2912733529dcb093cbeac44d031767ec1c0e434d720f6166e011b59c48b62b1c59ccb88d928d66082921b4bf6727a98b66fbd50 SHA512 d523477dfabcca81c68eeefd51673c72a6c7bf3c97ee70c0cf5ecfdf5988636693cfc0c548e97e4efeb1652f7f67b07ca224f5affea58450011d70cfb152430c
MISC metadata.xml 379 BLAKE2B 2bf8e348f9314b52a7229deeee8552e1a60e7942b078548f4ad5cc6b80ac6736f9e4564b617ca76788f948615074c409cd23603e73644b60b91b197aefeffaca SHA512 d1f896253bd8562247f3799f32f28d7408faff5d6e598ebc34e4b781691b2a5b2c61e3eabc3e01f0ad55d80660ce0501e8a95d3795f27d14d70de9f727ab5295
diff --git a/net-misc/httpstat/httpstat-1.3.1-r1.ebuild b/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..da4d547a2347
--- /dev/null
+++ b/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+PROPERTIES="test_network"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}
diff --git a/net-misc/httpstat/httpstat-1.3.1.ebuild b/net-misc/httpstat/httpstat-1.3.1.ebuild
index 9e8d0bbbcdc6..381ef2db3345 100644
--- a/net-misc/httpstat/httpstat-1.3.1.ebuild
+++ b/net-misc/httpstat/httpstat-1.3.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1
DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"