summaryrefslogtreecommitdiff
path: root/net-misc/httpstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /net-misc/httpstat
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'net-misc/httpstat')
-rw-r--r--net-misc/httpstat/Manifest4
-rw-r--r--net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch31
-rw-r--r--net-misc/httpstat/httpstat-1.3.1.ebuild28
-rw-r--r--net-misc/httpstat/metadata.xml13
4 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/httpstat/Manifest b/net-misc/httpstat/Manifest
new file mode 100644
index 000000000000..5d726a418dbc
--- /dev/null
+++ b/net-misc/httpstat/Manifest
@@ -0,0 +1,4 @@
+AUX httpstat-1.2.1-gentoo-tests.patch 840 BLAKE2B 478fc8c29c816be383def1d2f2194fe7d0fb888487c45afeba9b3a7808bbc01cbf1c836ee14b5f57115e19a1f63537736d137e19b3e1eac9b8af65f3519d5142 SHA512 6e904552c42e8d5cc9f6b298902601cb7ce1304ba2c85f0910f508ac09e5257562e7ed94fb0462512f02caff2a83fa2bb6ec35045a720e25c4f91e976cd1c99b
+DIST httpstat-1.3.1.tar.gz 97691 BLAKE2B f7a5388c3891c1caac654c6c9be425864e2a037eba2e12229ec72c847864f7be23b64d5450ebb42f976335f5b6ca878f1ee555ee3b2178c1a10c5969f883604d SHA512 bca91afe14d50af37c741ca4baa7d3843b010bb6dc012c72bd28c43f59099c20628cadc4dd80652dffeb1d26fb07f5cf156a3f6bf9eba1f6e121d4b250020b46
+EBUILD httpstat-1.3.1.ebuild 712 BLAKE2B 354747729c2e4d4cbf6afdd7e424e0d04772fc6504970bf090737970f201740cf5b3df5e10e2ae962b6cff5c42c57eb4b251937c2250d3d16e4e00a0e09a72af SHA512 e9861ee10dd6e58a5172b8c12b603871509d24bf7fce119adf5d6075cba55c03b79574e4832134def71b1f94b1ab06d3c80ecd290bddc8f00c11c9b045c71497
+MISC metadata.xml 438 BLAKE2B 06e46ab9f98e01534d2a49fc7a7715daa4bc621453a6f5799d6f969a2b8925802feba503d3a52d68186035fe9cb59659589bbd9c4c413486609e9cb78d6dd126 SHA512 29dfe149f8c10fd8e9a570f8ba19e601d147acf1b3b969dc99664bbf7dd18a5969a6877b14f04618938f43fecac820317c23cdfa786c9f63cc9f6aba2f01878d
diff --git a/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch b/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
new file mode 100644
index 000000000000..0fcb6523e6e1
--- /dev/null
+++ b/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
@@ -0,0 +1,31 @@
+- Testscript doesn't need to run tests for multiple python implementations,
+ PM will take care of that.
+
+- Disabling test which requires specific locales.
+
+--- a/httpstat_test.sh
++++ b/httpstat_test.sh
+@@ -19,8 +19,7 @@ function title() {
+ http_url="google.com"
+ https_url="https://http2.akamai.com"
+
+-for pybin in python python3; do
+-#for pybin in python; do
++for pybin in python; do
+ echo
+ echo "# Test in $pybin"
+
+@@ -40,9 +39,9 @@ for pybin in python python3; do
+ main_silent $https_url
+ assert_exit 0
+
+- title "comma decimal language (ru_RU)"
+- LC_ALL=ru_RU main_silent $http_url
+- assert_exit 0
++ #title "comma decimal language (ru_RU)"
++ #LC_ALL=ru_RU main_silent $http_url
++ #assert_exit 0
+
+ title "HTTPSTAT_DEBUG"
+ HTTPSTAT_DEBUG=true main $http_url | grep -q 'HTTPSTAT_DEBUG=true'
+
diff --git a/net-misc/httpstat/httpstat-1.3.1.ebuild b/net-misc/httpstat/httpstat-1.3.1.ebuild
new file mode 100644
index 000000000000..975c753128f4
--- /dev/null
+++ b/net-misc/httpstat/httpstat-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}
diff --git a/net-misc/httpstat/metadata.xml b/net-misc/httpstat/metadata.xml
new file mode 100644
index 000000000000..6a6902f9156c
--- /dev/null
+++ b/net-misc/httpstat/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/reorx/httpstat/issues</bugs-to>
+ <remote-id type="github">reorx/httpstat</remote-id>
+ <remote-id type="pypi">httpstat</remote-id>
+ </upstream>
+</pkgmetadata>