summaryrefslogtreecommitdiff
path: root/net-misc/gsutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-misc/gsutil
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-misc/gsutil')
-rw-r--r--net-misc/gsutil/Manifest2
-rw-r--r--net-misc/gsutil/gsutil-5.9.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/net-misc/gsutil/Manifest b/net-misc/gsutil/Manifest
index a95805e3233c..c2e6a758545b 100644
--- a/net-misc/gsutil/Manifest
+++ b/net-misc/gsutil/Manifest
@@ -4,6 +4,8 @@ AUX gsutil-4.50-boto-tests.patch 1483 BLAKE2B 9d40250f7a836535297da411bda76430dc
AUX gsutil-4.50-tests.patch 2451 BLAKE2B d84d1cd31eeabb3c0ecbb4b4850ec30d5f96e641b135b6c7fe6e7442edcfc4d2d076858b6fe1365f9424d32c81d9b818885df03f66405dfb8ca4d2149ee33ab5 SHA512 007e07b54a5f4182586f3defbc070f5883356214cb0e28861df66509c414d8bbde5718fd8598bcf023e9971331a34b2f1aefd89350e6d3c97e93ae80176b2d5a
DIST gsutil_4.60.tar.gz 4012900 BLAKE2B d3d1b57d5b0d42b1b454944efe8d62855b665d3772817c636568ef49c79ae2c566ef08c4c6e1bd3c9829471561865b64b3beec8d3911d6766748337aa1b1fc3e SHA512 18ab701cbb60513d66e8b96ced28cfe65dc0f210435fb5ffbcbfab3541ec7ed051db726e52239796d9579d0928953f610064279a3ee1e5b5c06cec963493804c
DIST gsutil_4.68.tar.gz 4459899 BLAKE2B 9855d379ba0483f1a33e4e05546444ff492c72d241ff0e5ca4f6c798c91b0c8d729247bf5fbaa39c411eb7a7e3f1fa701363898b903ba11c1bdf41c7e969c44d SHA512 b4af124808f34b5c0aa1d31b6d1bdbdeb451d39a246d4f2876ef664b6b485cdc5dc63bc3992ca4b7b33c72a00fc5119b931625e2c3230970bf0baa6389715e39
+DIST gsutil_5.9.tar.gz 11620858 BLAKE2B 09f2a79d14458a6545c45df23bd86a2769a00441ff03ae47a984cf18ae20c38e7b725f148c4e1d465f850f89871ad70b29463b8c829674d9d70d330b008595c7 SHA512 4916f3ac9c00c310a3dbc342ea0ab245cdf6952a4cee4e5b810f73254fb93439bcd7be35acbedac43501c3f19d8851848eeeff5b6ada6f31d93d478809518e35
EBUILD gsutil-4.60-r1.ebuild 3072 BLAKE2B 267dbbd52f525a90532b151eac417b5ad3abc88705b698c84ba765a4f71494ba39e858c0912dbba1f33fb56ed83f7e055d710d2330563c3d74838c134de01aa3 SHA512 c4c536f87b66a699b8b28da4b26245f923b9132e2f69369cc53dbe0baa051e15089a92b03031428b742b1f7ec035a2b09148746aff80822c508191f07fdbe93b
EBUILD gsutil-4.68.ebuild 3037 BLAKE2B 0fc9cdc2fbb439682e80a3c3333c3ddb79a9065285f36e94199a4601eeae16d7471002fb5d3af3291bf77122aee40bc4658ded78c0f15234e0f3848412bb1bee SHA512 fff0bf4340e89fc6803725e569e68314ffe96f7113ba5d8c7d29c46e158b2dbb6567f79f1b321949c143dbfc12bf9d46e13711c33abc56e4d80a09e975aab1c0
+EBUILD gsutil-5.9.ebuild 2921 BLAKE2B 985dd61bc358cacf80b046d494f3dc237e5eaa297d079dac988cb0c9a853dad383fb39cd683a437d1cc260725ea0f39c9eab569db044322a1d5ea67843203673 SHA512 8efc4a466896c3208a1b8ba233d0467a9595ddd59d709d75a9a9ab9cf79286ae9bb4987fae53ab56d105d4468695928f42635467b4b832f454444844991c8355
MISC metadata.xml 515 BLAKE2B 3e6c5322e5a945b1ea9e073ba98e135fdebf5d28f34bd6e5116f11668bf3505a6b8ab6f770348f2318c2bd3aa3aef782738e14ef6de60ee7c6fc1413a4a5a9c0 SHA512 53a143192dd605277e3ac4b8875400fbbcb892964e521de8768894f40580169d8ffd68f715a97f692b881ae6dc578a79e8d4573528bbdd881ffe4112d0d59734
diff --git a/net-misc/gsutil/gsutil-5.9.ebuild b/net-misc/gsutil/gsutil-5.9.ebuild
new file mode 100644
index 000000000000..2dd866b29dda
--- /dev/null
+++ b/net-misc/gsutil/gsutil-5.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="command line tool for interacting with cloud storage services"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
+SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.49.0[${PYTHON_USEDEP}]
+ >=dev-python/crcmod-1.7[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.14.1[${PYTHON_USEDEP}]
+ >=dev-python/gcs-oauth2-boto-plugin-3.0[${PYTHON_USEDEP}]
+ >=dev-python/google-apitools-0.5.32[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/google-reauth-python-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.20.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/gsutil-4.41-tests.patch"
+ "${FILESDIR}/gsutil-4.50-boto-tests.patch"
+ "${FILESDIR}/gsutil-4.50-tests.patch"
+)
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( README.md CHANGES.md )
+
+# Needs to talk to Google to run tests.
+RESTRICT+=" test"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # NB: We don't delete all of boto/ because the tests are imported by the
+ # production code. The same reason we can't delete gslib/tests/. We can
+ # delete the main boto library and use the system version though.
+ rm -r gslib/vendored/boto/boto || die
+
+ # Fails to compile with py3.
+ rm gslib/vendored/boto/tests/mturk/cleanup_tests.py gslib/tests/test_wrapped_credentials.py || die
+
+ # monotonic is only used by bundled fasteners that we do not install.
+ sed -i \
+ -e 's/mock==/mock>=/' \
+ -e '/monotonic/d' \
+ setup.py || die
+ # Sanity check we didn't miss any updates.
+ grep '==' setup.py && die "Need to update version requirements"
+
+ # For debugging purposes, temporarily uncomment this in order to
+ # show hidden tracebacks.
+ #sed -e 's/^ except OSError as e:$/&\n raise/' \
+ # -e 's/def _HandleUnknownFailure(e):/&\n raise/' \
+ # -i gslib/__main__.py || die
+
+ # create_bucket raised ResponseNotReady.
+ sed -i \
+ -e 's/test_cp_unwritable_tracker_file/_&/' \
+ -e 's/test_cp_unwritable_tracker_file_download/_&/' \
+ gslib/tests/test_cp.py || die
+
+ sed -i -E -e 's/(executable_prefix =).*/\1 [sys.executable]/' \
+ gslib/commands/test.py || die
+
+ # IOError: close() called during concurrent operation on the same file object.
+ sed -i -e 's/sys.stderr.close()/#&/' \
+ gslib/tests/testcase/unit_testcase.py || die
+}
+
+python_test() {
+ BOTO_CONFIG="${FILESDIR}/dummy.boto" \
+ "${EPYTHON}" gslib/__main__.py test -u || die "tests failed with ${EPYTHON}"
+}