summaryrefslogtreecommitdiff
path: root/net-misc/geoipyupdate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-19 12:05:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-19 12:05:02 +0100
commitb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (patch)
treea0158050dac0a7ebfb9df4f667ec6ad2dd185538 /net-misc/geoipyupdate
parent2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (diff)
gentoo auto-resync : 19:04:2024 - 12:05:02
Diffstat (limited to 'net-misc/geoipyupdate')
-rw-r--r--net-misc/geoipyupdate/Manifest3
-rw-r--r--net-misc/geoipyupdate/geoipyupdate-0.0.1.ebuild26
-rw-r--r--net-misc/geoipyupdate/metadata.xml7
3 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/geoipyupdate/Manifest b/net-misc/geoipyupdate/Manifest
new file mode 100644
index 000000000000..aafdd5672e3c
--- /dev/null
+++ b/net-misc/geoipyupdate/Manifest
@@ -0,0 +1,3 @@
+DIST geoipyupdate-0.0.1.tar.gz 17000 BLAKE2B e68d044fc748f0876745a21cb77e8098367ab7e260ff53e0e6b68ad88d7c1deb4b6f3977eeaf61a1b0a54f30f0fc32e302a89e996a9ccb69f9dc9c48c3d0df03 SHA512 8e78866f083b3ab8ef445d82e4d9081f7f59437348638e951c615f610e382ac5b7f9dc08c3a28735322442a22d276cfed12dcd375ac613f0d18f10ef94b200b7
+EBUILD geoipyupdate-0.0.1.ebuild 629 BLAKE2B f1e3031215f01a5e770f604cb156c8552b396d11d90036d3b24f9b89976b2d498a4eb14919ad41dc2c6dc45c6bf3f1a87b42b0f7e52fd38acb673b6ffc22ded9 SHA512 fb5281140577579e89775381a6308351b1c92bae06426f04f2a86d92dac560df1ae8cfd509aa17965ac238a443b8e7ac806e433a2c6266690d134b5ea99fb759
+MISC metadata.xml 219 BLAKE2B 27094593eb47f098fe9df926d3a827b65c2ca39ac6b03d392efe2c19d646274e5b462f65a7177ba2556a9167c994544688e53a3df810dc7f86ae43c4a75fd59e SHA512 e990bf6d766d6c0380344187a03b66380e4ed7a1554dd7a900ccf1f6f2dd3a51b06b382cedd5c73e0ad75301436b351fea0e7f1fb720c3d1345a8958554d341c
diff --git a/net-misc/geoipyupdate/geoipyupdate-0.0.1.ebuild b/net-misc/geoipyupdate/geoipyupdate-0.0.1.ebuild
new file mode 100644
index 000000000000..6212aa8469a4
--- /dev/null
+++ b/net-misc/geoipyupdate/geoipyupdate-0.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple python replacement for the MaxMind geoipupdate program"
+HOMEPAGE="https://michael.orlitzky.com/code/geoipyupdate.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst doc/geoipyupdate-sample.toml )
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/man1/geoipyupdate.1
+}
diff --git a/net-misc/geoipyupdate/metadata.xml b/net-misc/geoipyupdate/metadata.xml
new file mode 100644
index 000000000000..c6418674131d
--- /dev/null
+++ b/net-misc/geoipyupdate/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>