summaryrefslogtreecommitdiff
path: root/net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
commit8bcae5a5a332db9dc28c20b7a5f28337d8335254 (patch)
treef5e955d5d9283743bda70a7d99a915db594b8a50 /net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild
parent74dcbf5a63cafe2678e2a397e1002dd691425200 (diff)
gentoo auto-resync : 05:04:2025 - 01:34:33HEADmaster
Diffstat (limited to 'net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild')
-rw-r--r--net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild b/net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild
new file mode 100644
index 000000000000..42ac0a2c95f2
--- /dev/null
+++ b/net-misc/geoipyupdate/geoipyupdate-0.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple python replacement for the MaxMind geoipupdate program"
+HOMEPAGE="https://michael.orlitzky.com/code/geoipyupdate.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst doc/geoipyupdate-sample.toml )
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/man1/geoipyupdate.1
+}