summaryrefslogtreecommitdiff
path: root/net-misc/freerdp/freerdp-2.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 00:49:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 00:49:43 +0000
commitec33f4bcbd3944dc39c56a98cde12232684932cf (patch)
tree3f7cc55fc8e88c98187f129228aa74a73ddcb18a /net-misc/freerdp/freerdp-2.9999.ebuild
parent5c94a4b3d11ad7b169e23bd604cf403c96bf4f1c (diff)
gentoo auto-resync : 18:03:2024 - 00:49:43
Diffstat (limited to 'net-misc/freerdp/freerdp-2.9999.ebuild')
-rw-r--r--net-misc/freerdp/freerdp-2.9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-misc/freerdp/freerdp-2.9999.ebuild b/net-misc/freerdp/freerdp-2.9999.ebuild
index 035df26f5b1e..6a6c319f26f5 100644
--- a/net-misc/freerdp/freerdp-2.9999.ebuild
+++ b/net-misc/freerdp/freerdp-2.9999.ebuild
@@ -23,15 +23,13 @@ HOMEPAGE="https://www.freerdp.com/"
LICENSE="Apache-2.0"
SLOT="2"
-IUSE="alsa cpu_flags_arm_neon client cups debug doc +ffmpeg gstreamer icu jpeg kerberos openh264 pulseaudio server smartcard systemd test tools usb valgrind wayland X xinerama xv"
+IUSE="alsa cpu_flags_arm_neon client cups debug +ffmpeg gstreamer icu jpeg kerberos openh264 pulseaudio server smartcard systemd test usb valgrind wayland X xinerama xv"
RESTRICT="!test? ( test )"
BDEPEND="
virtual/pkgconfig
- X? ( doc? (
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto
- ) )
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
"
COMMON_DEPEND="
@@ -98,7 +96,6 @@ RDEPEND="${COMMON_DEPEND}
!net-misc/freerdp:0
client? ( !net-misc/freerdp:3[client] )
server? ( !net-misc/freerdp:3[server] )
- tools? ( !net-misc/freerdp:3[tools] )
"
option() {
@@ -126,7 +123,7 @@ src_configure() {
-DWITH_CUPS=$(option cups)
-DWITH_CLIENT=$(option client)
-DWITH_DEBUG_ALL=$(option debug)
- -DWITH_MANPAGES=$(option doc)
+ -DWITH_MANPAGES=ON
-DWITH_FFMPEG=$(option ffmpeg)
-DWITH_SWSCALE=$(option ffmpeg)
-DWITH_CAIRO=$(option !ffmpeg)
@@ -147,7 +144,7 @@ src_configure() {
-DWITH_XINERAMA=$(option xinerama)
-DWITH_XV=$(option xv)
-DWITH_WAYLAND=$(option_client wayland)
- -DWITH_WINPR_TOOLS=$(option tools)
+ -DWITH_WINPR_TOOLS=$(option server)
)
cmake_src_configure
}