summaryrefslogtreecommitdiff
path: root/net-misc/freerdp/freerdp-2.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-misc/freerdp/freerdp-2.9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-misc/freerdp/freerdp-2.9999.ebuild')
-rw-r--r--net-misc/freerdp/freerdp-2.9999.ebuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/net-misc/freerdp/freerdp-2.9999.ebuild b/net-misc/freerdp/freerdp-2.9999.ebuild
index 48ee51c92773..fa7d73ce5c84 100644
--- a/net-misc/freerdp/freerdp-2.9999.ebuild
+++ b/net-misc/freerdp/freerdp-2.9999.ebuild
@@ -23,7 +23,7 @@ HOMEPAGE="http://www.freerdp.com/"
LICENSE="Apache-2.0"
SLOT="0/2"
-IUSE="alsa +client cpu_flags_arm_neon cups debug doc +ffmpeg gstreamer jpeg libav libressl openh264 pulseaudio server smartcard systemd test usb wayland X xinerama xv"
+IUSE="alsa cpu_flags_arm_neon cups debug doc +ffmpeg gstreamer jpeg libressl openh264 pulseaudio server smartcard systemd test usb wayland X xinerama xv"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -32,26 +32,21 @@ RDEPEND="
sys-libs/zlib:0
alsa? ( media-libs/alsa-lib )
cups? ( net-print/cups )
- client? (
- usb? (
- virtual/libudev:0=
- sys-apps/util-linux:0=
- dev-libs/dbus-glib:0=
- virtual/libusb:1=
- )
- X? (
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- xinerama? ( x11-libs/libXinerama )
- xv? ( x11-libs/libXv )
- )
+ usb? (
+ virtual/libudev:0=
+ sys-apps/util-linux:0=
+ dev-libs/dbus-glib:0=
+ virtual/libusb:1=
)
- ffmpeg? (
- libav? ( media-video/libav:0= )
- !libav? ( media-video/ffmpeg:0= )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ xv? ( x11-libs/libXv )
)
+ ffmpeg? ( media-video/ffmpeg:0= )
!ffmpeg? (
x11-libs/cairo:0=
)
@@ -88,10 +83,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- client? ( X? ( doc? (
+ X? ( doc? (
app-text/docbook-xml-dtd:4.1.2
app-text/xmlto
- ) ) )
+ ) )
"
src_configure() {
@@ -100,7 +95,6 @@ src_configure() {
-DCHANNEL_URBDRC=$(usex usb ON OFF)
-DWITH_ALSA=$(usex alsa ON OFF)
-DWITH_CCACHE=OFF
- -DWITH_CLIENT=$(usex client ON OFF)
-DWITH_CUPS=$(usex cups ON OFF)
-DWITH_DEBUG_ALL=$(usex debug ON OFF)
-DWITH_MANPAGES=$(usex doc ON OFF)