summaryrefslogtreecommitdiff
path: root/net-misc/ethflop/ethflop-20191003-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-23 06:06:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-23 06:06:50 +0100
commit98c7fa9070b6b423d52dfb59567ec7ef0d5f234d (patch)
tree15a9168c34e20acc6a8707fe4bee72b86d20f86c /net-misc/ethflop/ethflop-20191003-r2.ebuild
parent0e1abc96fea41c994e56391bd01c5c9298236783 (diff)
gentoo auto-resync : 23:04:2023 - 06:06:49
Diffstat (limited to 'net-misc/ethflop/ethflop-20191003-r2.ebuild')
-rw-r--r--net-misc/ethflop/ethflop-20191003-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/ethflop/ethflop-20191003-r2.ebuild b/net-misc/ethflop/ethflop-20191003-r2.ebuild
new file mode 100644
index 000000000000..51efe0cd19d7
--- /dev/null
+++ b/net-misc/ethflop/ethflop-20191003-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A network-backed floppy emulator for DOS"
+HOMEPAGE="http://ethflop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="tsr"
+
+BDEPEND="
+ app-arch/unzip
+ tsr? ( dev-lang/nasm )
+"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ tc-export CC
+ default
+
+ use tsr && emake tsr
+}
+
+src_install() {
+ dobin ethflopd
+
+ if use tsr; then
+ insinto /usr/share/ethflop
+ doins ethflop.com
+ fi
+
+ newinitd "${FILESDIR}"/ethflopd.initd ethflopd
+ newconfd "${FILESDIR}"/ethflopd.confd ethflopd
+ systemd_newunit "${FILESDIR}"/ethflopd.service-r1 ethflopd.service
+
+ dodoc ethflop.txt
+}