summaryrefslogtreecommitdiff
path: root/net-misc/ena-driver/ena-driver-2.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
commit511da2e8215301136bf13531af2329e9703addaf (patch)
treee5b21768118114c1882a1f772d0565fb3ba1801a /net-misc/ena-driver/ena-driver-2.11.0.ebuild
parentd095cf23cccb27f0f047472717fdf96bf857110d (diff)
gentoo auto-resync : 01:12:2023 - 11:06:48
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.11.0.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.11.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.11.0.ebuild b/net-misc/ena-driver/ena-driver-2.11.0.ebuild
new file mode 100644
index 000000000000..eb8ed9525827
--- /dev/null
+++ b/net-misc/ena-driver/ena-driver-2.11.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
+HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
+SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
+
+CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
+DOCS=(
+ README.rst
+ RELEASENOTES.md
+ ENA_Linux_Best_Practices.rst
+)
+
+src_compile() {
+ local modlist=( ena=net )
+ local modargs=( CONFIG_MODULE_SIG=n BUILD_KERNEL="${KV_FULL}" )
+ linux-mod-r1_src_compile
+}