summaryrefslogtreecommitdiff
path: root/net-misc/econnman/econnman-1.1_p20160305.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-misc/econnman/econnman-1.1_p20160305.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-misc/econnman/econnman-1.1_p20160305.ebuild')
-rw-r--r--net-misc/econnman/econnman-1.1_p20160305.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/econnman/econnman-1.1_p20160305.ebuild b/net-misc/econnman/econnman-1.1_p20160305.ebuild
new file mode 100644
index 000000000000..be864310ff2f
--- /dev/null
+++ b/net-misc/econnman/econnman-1.1_p20160305.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="ConnMan User Interface written with EFL & python"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/econnman/ https://www.enlightenment.org/"
+SRC_URI="https://dev.gentoo.org/~juippis/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/efl[X,connman]
+ $(python_gen_cond_dep '
+ dev-python/python-efl[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ python_fix_shebang econnman-bin.in
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -r "${ED}"/var/ || die
+}