summaryrefslogtreecommitdiff
path: root/net-misc/dhcpcd-ui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 06:05:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 06:05:12 +0100
commit431cb94e4e840d61ea21c2c2bd10e07fc27b5538 (patch)
treea5ea0afac6f3ea24f6bafd60b9199e358b1a243f /net-misc/dhcpcd-ui
parent94ead5b3c01213a82c9b72a2df165452421db42b (diff)
gentoo auto-resync : 09:10:2023 - 06:05:11
Diffstat (limited to 'net-misc/dhcpcd-ui')
-rw-r--r--net-misc/dhcpcd-ui/Manifest3
-rw-r--r--net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild84
-rw-r--r--net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch13
3 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/dhcpcd-ui/Manifest b/net-misc/dhcpcd-ui/Manifest
index 4bdcf6f00f8a..fbba90d8f620 100644
--- a/net-misc/dhcpcd-ui/Manifest
+++ b/net-misc/dhcpcd-ui/Manifest
@@ -1,3 +1,6 @@
+AUX dhcpcd-ui-0.7.9-respect-qmake-args.patch 316 BLAKE2B 4015a89728f68685c46268ac86af761e060ce40e1232e088478e9f29defca5ac6a9834161c8c8503e11df04bd583cea97940078156f3945bd14c17ce2354c8e7 SHA512 950d56277d934661136f236b5d402d427a47932238c37242048f2d093a1ad67aa2c30106c9ee9b828b9f958f81dcefa51d3db3ffdad1cbde6d6a0c4f862744b3
DIST dhcpcd-ui-0.7.8.tar.xz 135028 BLAKE2B f3e79bb00708e2ce2ebb93d917506bb0fb015071b415768c47979d7f2b5e35d6f22bf71a58c43989dedc6561f0a8be738824f06627d2fa0995e335d7ef1925cd SHA512 5f0d2c32c32fc141feca0ab43a531d9b4f45e071a8a1e3ee1923d6394a3e5d6322e6f7e607b91154af4cfee93d649164c7ed3b805731dfc242c3ac367ec156c4
+DIST dhcpcd-ui-0.7.9.tar.xz 104100 BLAKE2B 7e2bbbb9ad657deccc16296a0c7191f35fa15dbc84f1f8ac4f8ac5de4c56e5948da457398409527774ffc62e58659cac2dd37aa66842179f710db04a9791ab9e SHA512 fe0c9ff2f777e7b97438eb50507fce765b8e18b1a71883d76e9b6570a18e6f13414f8e64d8034f9c3352496775c283a0540e331ec449d6fbe48ddc8d64e14691
EBUILD dhcpcd-ui-0.7.8.ebuild 1317 BLAKE2B 9184c0a56b1163f7ddf4a2de6f84bf6a3ee3b0d25029686aa55c1a8f4ed00a318ca586bde1b5798ca2c42afbe5979d098a997eb0e9e9ea517384f97aab0036f8 SHA512 d19ab69d655ae6886654cc69fb49a2ec5b8bd2c07d66fc62f92806e6ce437f5425783ed365dac7f91c05a6dd8fbf7b1780f8b65ed9a8171523f088fe57c7dee8
+EBUILD dhcpcd-ui-0.7.9.ebuild 1672 BLAKE2B 120b28827f6d076bad6441c2332fc1eaf39aa67174e2a6eec45d73b44e55ea5504c157b60cb45e19aa237186934f09c1d781202e7e268993099cc507a6235719 SHA512 c68f7d4fce1fa8376c445a459b095f609f89df55895089785557c2289273745e754da22d1b65b4d2d8aa06fc03c608922d0985ec9c2dc38596a3464580e3d4c2
MISC metadata.xml 263 BLAKE2B b158e1cc9bc26face8e3b7b4d791a998a637db216ab41d8b809061c1652df0028ff4ffdd67ca515be38304b2a6c53d366fcf05b3e06e816e67e9689b1aadb46b SHA512 2b6c4b4581d1103715b80c20f9d0c5afe2899935f9d18157b8336e72fa5cbf646d38ebd90692af3c8727b1f8484aab162dceb280b0aa331f68bf9fd20a95d26d
diff --git a/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild
new file mode 100644
index 000000000000..b29581f35d00
--- /dev/null
+++ b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils systemd toolchain-funcs xdg
+
+DESCRIPTION="Desktop notification and configuration for dhcpcd"
+HOMEPAGE="https://github.com/NetworkConfiguration/dhcpcd-ui https://roy.marples.name/projects/dhcpcd-ui/"
+SRC_URI="https://github.com/NetworkConfiguration/dhcpcd-ui/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk libnotify ncurses qt5"
+
+# Qt handles notifications separately, no need for libnotify there
+REQUIRED_USE="
+ libnotify? ( gtk )
+"
+
+BDEPEND="
+ media-gfx/cairosvg
+ virtual/libintl
+"
+DEPEND="
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ )
+ libnotify? ( x11-libs/libnotify )
+ ncurses? ( sys-libs/ncurses:= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/mesa
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-misc/dhcpcd-6.4.4
+"
+
+src_configure() {
+ local myeconfargs=(
+ --without-qt
+ --without-qt5
+ $(use_enable debug)
+ $(use_enable libnotify notification)
+ $(use_with gtk gtk 'gtk+-3.0')
+ $(use_with ncurses curses)
+ )
+
+ tc-export AR CC CXX
+
+ econf "${myeconfargs[@]}"
+
+ if use qt5 ; then
+ cd src/dhcpcd-qt || die
+ eqmake5 PREFIX="${EPREFIX}/usr" SYSCONFDIR="${EPREFIX}/etc"
+ fi
+}
+
+src_compile() {
+ default
+
+ use qt5 && emake -C src/dhcpcd-qt
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ use qt5 && emake -C src/dhcpcd-qt DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch
new file mode 100644
index 000000000000..2ed516048e5d
--- /dev/null
+++ b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index ec61c80..9372b38 100755
+--- a/configure
++++ b/configure
+@@ -230,7 +230,7 @@ if [ -n "$LDFLAGS" ]; then
+ echo "LDFLAGS=" >>$CONFIG_MK
+ echo "LDFLAGS+= $LDFLAGS" >>$CONFIG_MK
+ fi
+-QMAKE_CONFIG=
++#QMAKE_CONFIG
+
+ for x in $INCLUDEDIR; do
+ echo "CPPFLAGS+= -I$x" >>$CONFIG_MK