summaryrefslogtreecommitdiff
path: root/net-misc/dcetest/dcetest-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/dcetest/dcetest-2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/dcetest/dcetest-2.0.ebuild')
-rw-r--r--net-misc/dcetest/dcetest-2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/dcetest/dcetest-2.0.ebuild b/net-misc/dcetest/dcetest-2.0.ebuild
new file mode 100644
index 000000000000..64d606b19783
--- /dev/null
+++ b/net-misc/dcetest/dcetest-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="dcetest is a clone of the Windows rpcinfo"
+HOMEPAGE="http://www.atstake.com/research/tools/info_gathering/"
+SRC_URI="http://www.atstake.com/research/tools/info_gathering/dcetest.tar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+DEPEND="sys-apps/sed"
+RDEPEND=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # cleanup the makefile a little
+ sed -e '/^CC/d' -i Makefile
+ sed -e 's/CFLAGS.*/CFLAGS += -Wall -funsigned-char -fPIC/g' -i Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin dcetest || die
+ dodoc CHANGELOG README VERSION nt4sp6adefault.txt out out.txt out2.txt w2ksp0.txt
+}