summaryrefslogtreecommitdiff
path: root/net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild')
-rw-r--r--net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild b/net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild
new file mode 100644
index 000000000000..d828ff6f45dd
--- /dev/null
+++ b/net-misc/dahdi-tools/dahdi-tools-2.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="Userspace tools to configure the kernel modules from net-misc/dahdi"
+HOMEPAGE="http://www.asterisk.org"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${P}.tar.gz
+ mirror://gentoo/gentoo-${PN}-patchset-0.4.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ppp"
+
+DEPEND="dev-libs/newt
+ ppp? ( net-dialup/ppp )
+ >=net-misc/dahdi-2.5.0
+ !net-misc/zaptel
+ >=sys-kernel/linux-headers-2.6.35
+ virtual/libusb:0"
+RDEPEND="${DEPEND}"
+
+EPATCH_SUFFIX="diff"
+PATCHES=( "${WORKDIR}/${PN}-patchset" )
+
+src_compile() {
+ default_src_compile
+ emake tests
+ use ppp && emake -C ppp
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use ppp && emake DESTDIR="${D}" -C ppp install
+ emake DESTDIR="${D}" config
+
+ dosbin patgen pattest patlooptest hdlcstress hdlctest hdlcgen hdlcverify timertest
+
+ # install init scripts
+ newinitd "${FILESDIR}"/dahdi.init2 dahdi
+ newinitd "${FILESDIR}"/dahdi-autoconf.init2 dahdi-autoconf
+ newconfd "${FILESDIR}"/dahdi-autoconf.conf2 dahdi-autoconf
+}