summaryrefslogtreecommitdiff
path: root/net-misc/curl/curl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 09:47:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 09:47:51 +0100
commit65a4d80ebaba5d4d407b3d09320b337e0ca20f0a (patch)
tree8a0a31fde569e875a6a429ce5473050781aa7803 /net-misc/curl/curl-9999.ebuild
parent29d63ef1ebd8704a96d50408d409b9ef0ff3787b (diff)
gentoo auto-resync : 09:06:2023 - 09:47:51
Diffstat (limited to 'net-misc/curl/curl-9999.ebuild')
-rw-r--r--net-misc/curl/curl-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index bd074d803563..770410045476 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
-inherit autotools multilib-minimal prefix verify-sig
+inherit autotools multilib-minimal multiprocessing prefix verify-sig
DESCRIPTION="A Client that groks URLs"
HOMEPAGE="https://curl.se/"
@@ -318,7 +318,10 @@ multilib_src_test() {
# Note: if needed, we can skip specific tests. See e.g. Fedora's packaging
# or just read https://github.com/curl/curl/tree/master/tests#run.
# Note: we don't run the testsuite for cross-compilation.
- multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p"
+ # Upstream recommend 7*nproc as a starting point for parallel tests.
+ # The network sandbox causes tests 241 and 1083 to fail; these are typically skipped
+ # as most gentoo users don't have an 'ip6-localhost'
+ multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((7*$(makeopts_jobs))) !241 !1083"
}
multilib_src_install_all() {