summaryrefslogtreecommitdiff
path: root/net-misc/connman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-misc/connman
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest3
-rw-r--r--net-misc/connman/connman-9999.ebuild100
-rw-r--r--net-misc/connman/metadata.xml1
3 files changed, 103 insertions, 1 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index fbcd2fbe3333..5f86977c8cdf 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -3,4 +3,5 @@ AUX connman.confd 728 BLAKE2B c4ee3b02bddaaa99af6aab2ecb0300cc7d67cfc73114d94863
AUX connman.initd2 479 BLAKE2B 4ef210f405b196fe2fe0fa2e95188cded69d3da37e9f368f500f95db48e1e51e881a5f04479e501283c70712f99a20569b9bf2c6793dc36fb37c68bafb9ff8c3 SHA512 6b636b53f1bede22f04d7107c0e5032dbd425032f317692b2ba39f810371eb89a840ced5f8988d26d384eb6e61ea967d1088c4f0ba6cff42782d9d39300b2a40
DIST connman-1.37.tar.xz 707752 BLAKE2B ad8993764a444d205b0a8cf1ad38acc249a1a28014e6f4e5a89c8662194ad2e2ee6091b51445b88a885808461413b3aaf88eeb7b75a32f417b578d2da80a2e9f SHA512 5d5363105aedd0c9d609dd5c64eb832d9ff80923a944d9d3738337a61f180ded227f2ae1ff7912bed8826b35f0cfd20488e3ffd3801f0e53e90f98498e19efb6
EBUILD connman-1.37.ebuild 2596 BLAKE2B 6c8ccfffaaad05f5a09b93b11dd9fc5000c3899db79f84d6bad9a959ebea5c01f21f0bef203fa1524aec6a16e384c0167167b8c3915bd230fb721b15e863ba8d SHA512 ff3f15f3258908c623d8ba0b6295a825984db6a905189595ae7fe506d316b3076d03b396324187852161245e555f257f4c0e8f560284bcdd38d3c593164bfb5c
-MISC metadata.xml 1158 BLAKE2B 57d083417dd0b186b1d45368f1ffab64d6283535ae6f25adfd6cd85d26f535544f0b89d7f731dbb876ba7acd1973abdd26ac7643c050adc9a433d321ffc9fb57 SHA512 2d272d638d9f9f06eb900736815eb0e401520f3ad86082beea541932626c5758e220f692931772ecafffbd60798f0df38e8c9e8a02b58c03743ed984955edb8b
+EBUILD connman-9999.ebuild 2728 BLAKE2B 40425b699009ba247ea64db4db90c86914c5d69c70614e9c1fd4071ad30d6ad73f1e7558befe877788b00d3e551973d93cd38f28519dc7f11c4e0b3f7d14751e SHA512 7b15cf1018816892e0d11011e9f6bdf823f140e10158b9a55a230b88e2f1a2980fcabee4d681c23f4939eb387fb8d93cc9400bd64a58dc61e9bddee1718161da
+MISC metadata.xml 1220 BLAKE2B 0d56b48507231a37eed6f84e5875ea55571a8cfc0379b7b16c3d74650fa011876b7466a96bfbcf7a9db9cc931c2662d678d33872082dec7b444dc404430e71bd SHA512 591edad65cd7efc59a63b207c5ea7b60b624ee91b3ab1d4aa165d4b2824640fffeca662d7f6ba34822e38777ceae9aa3caafd39d328294f245e988c77fbede5d
diff --git a/net-misc/connman/connman-9999.ebuild b/net-misc/connman/connman-9999.ebuild
new file mode 100644
index 000000000000..937b54ecf834
--- /dev/null
+++ b/net-misc/connman/connman-9999.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit autotools systemd tmpfiles
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+ SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ bluetooth? ( net-wireless/bluez )
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ iwd? ( net-wireless/iwd )
+ l2tp? ( net-dialup/xl2tpd )
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0= )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wireguard? ( >=net-libs/libmnl-1.0.0:0= )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable debug) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable examples test) \
+ $(use_enable iwd) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable networkmanager nmcompat) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable tools) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable wireguard) \
+ $(use_enable wispr wispr builtin) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/connman_resolvconf.conf
+}
diff --git a/net-misc/connman/metadata.xml b/net-misc/connman/metadata.xml
index b6bed9600f0d..a8e17b602a0e 100644
--- a/net-misc/connman/metadata.xml
+++ b/net-misc/connman/metadata.xml
@@ -18,5 +18,6 @@
<flag name="tools">Enable testing tools.</flag>
<flag name="vpnc">Use <pkg>net-vpn/vpnc</pkg> for cisco VPN support.</flag>
<flag name="wispr">Enable support for WISPr hotspot logins.</flag>
+ <flag name="wireguard">Enable WireGuard VPN support.</flag>
</use>
</pkgmetadata>