summaryrefslogtreecommitdiff
path: root/net-misc/connman/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/connman/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/connman/files')
-rw-r--r--net-misc/connman/files/connman-1.16-execinfo-assumptions.patch54
-rw-r--r--net-misc/connman/files/connman-1.31-xtables.patch54
-rw-r--r--net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch15
-rw-r--r--net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch6
-rw-r--r--net-misc/connman/files/connman.confd15
-rw-r--r--net-misc/connman/files/connman.initd222
-rw-r--r--net-misc/connman/files/connman.service11
7 files changed, 177 insertions, 0 deletions
diff --git a/net-misc/connman/files/connman-1.16-execinfo-assumptions.patch b/net-misc/connman/files/connman-1.16-execinfo-assumptions.patch
new file mode 100644
index 000000000000..5404414fc0ea
--- /dev/null
+++ b/net-misc/connman/files/connman-1.16-execinfo-assumptions.patch
@@ -0,0 +1,54 @@
+diff -uNr a/config.h.in b/config.h.in
+--- a/config.h.in 2013-07-02 17:41:03.715261748 +0000
++++ b/config.h.in 2013-07-02 17:41:21.707260667 +0000
+@@ -3,6 +3,9 @@
+ /* Define to 1 if you have the <dlfcn.h> header file. */
+ #undef HAVE_DLFCN_H
+
++/* Define to 1 if you have the <execinfo.h> header file. */
++#undef HAVE_EXECINFO_H
++
+ /* Define to 1 if you have the <inttypes.h> header file. */
+ #undef HAVE_INTTYPES_H
+
+diff -uNr a/configure.ac b/configure.ac
+--- a/configure.ac 2013-07-02 17:41:03.715261748 +0000
++++ b/configure.ac 2013-07-02 17:41:21.719260666 +0000
+@@ -181,6 +181,8 @@
+ AC_CHECK_FUNC(signalfd, dummy=yes,
+ AC_MSG_ERROR(signalfd support is required))
+
++AC_CHECK_HEADERS([execinfo.h], [], [])
++
+ AC_CHECK_LIB(dl, dlopen, dummy=yes,
+ AC_MSG_ERROR(dynamic linking loader is required))
+
+diff -uNr a/src/log.c b/src/log.c
+--- a/src/log.c 2013-07-02 17:41:03.727261747 +0000
++++ b/src/log.c 2013-07-02 17:42:12.717257603 +0000
+@@ -30,7 +30,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <syslog.h>
++#ifdef HAVE_EXECINFO_H
+ #include <execinfo.h>
++#endif
+ #include <dlfcn.h>
+
+ #include "connman.h"
+@@ -112,6 +114,7 @@
+
+ static void print_backtrace(unsigned int offset)
+ {
++#ifdef HAVE_EXECINFO_H
+ void *frames[99];
+ size_t n_ptrs;
+ unsigned int i;
+@@ -210,6 +213,7 @@
+
+ close(outfd[1]);
+ close(infd[0]);
++#endif
+ }
+
+ static void signal_handler(int signo)
diff --git a/net-misc/connman/files/connman-1.31-xtables.patch b/net-misc/connman/files/connman-1.31-xtables.patch
new file mode 100644
index 000000000000..84f4445e8da1
--- /dev/null
+++ b/net-misc/connman/files/connman-1.31-xtables.patch
@@ -0,0 +1,54 @@
+--- connman-1.31/src/iptables.c.old 2016-03-22 20:12:47.829460752 -0700
++++ connman-1.31/src/iptables.c 2016-03-22 21:33:36.835384724 -0700
+@@ -28,11 +28,11 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/errno.h>
+ #include <sys/socket.h>
+-#include <xtables.h>
++#include "connman_xtables.h"
+ #include <inttypes.h>
+
+ #include <linux/netfilter_ipv4/ip_tables.h>
+
+ #include "connman.h"
+--- connman-1.31/src/firewall.c.old 2016-03-22 21:29:01.959472262 -0700
++++ connman-1.31/src/firewall.c 2016-03-22 21:33:53.048144181 -0700
+@@ -23,11 +23,11 @@
+ #include <config.h>
+ #endif
+
+ #include <errno.h>
+
+-#include <xtables.h>
++#include "connman_xtables.h"
+ #include <linux/netfilter_ipv4/ip_tables.h>
+
+ #include "connman.h"
+
+ #define CHAIN_PREFIX "connman-"
+--- /dev/null 2016-03-18 06:21:16.372989086 -0700
++++ connman-1.31/include/connman_xtables.h 2016-03-22 21:32:21.349504786 -0700
+@@ -0,0 +1,21 @@
++#ifndef CONNMAN_XTABLES_H
++#define CONNMAN_XTABLES_H
++
++#include <linux/version.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 5, 0) || \
++ LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++#include <xtables.h>
++#else
++#ifdef __USE_MISC
++#define GENTOO_USE_MISC __USE_MISC
++#undef __USE_MISC
++#endif
++
++#include <xtables.h>
++
++#ifdef GENTOO_USE_MISC
++#define __USE_MISC GENTOO_USE_MISC
++#undef GENTOO_USE_MISC
++#endif
++#endif
++#endif
diff --git a/net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch b/net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch
new file mode 100644
index 000000000000..57ef5e8ccbac
--- /dev/null
+++ b/net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch
@@ -0,0 +1,15 @@
+--- connman-1.33/configure.ac.old 2016-10-09 11:26:43.137856416 -0700
++++ connman-1.33/configure.ac 2016-10-09 11:26:52.819722799 -0700
+@@ -281,11 +281,11 @@ AM_CONDITIONAL(NMCOMPAT, test "${enable_
+
+ AC_ARG_ENABLE(polkit, AC_HELP_STRING([--enable-polkit],
+ [enable PolicyKit support]),
+ [enable_polkit=${enableval}], [enable_polkit="no"])
+ if (test "${enable_polkit}" != "no"); then
+- POLKIT_DATADIR="`$PKG_CONFIG --variable=actiondir polkit`"
++ POLKIT_DATADIR="`$PKG_CONFIG --variable=actiondir polkit-gobject-1`"
+ POLKIT_DATADIR=""
+ if (test -z "${POLKIT_DATADIR}"); then
+ POLKIT_DATADIR="${datadir}/polkit-1/actions"
+ fi
+ AC_SUBST(POLKIT_DATADIR)
diff --git a/net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch b/net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch
new file mode 100644
index 000000000000..49bb8ba3c5a1
--- /dev/null
+++ b/net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch
@@ -0,0 +1,6 @@
+--- connman-1.33/scripts/connman_resolvconf.conf.in.old 2016-10-09 11:27:20.425341843 -0700
++++ connman-1.33/scripts/connman_resolvconf.conf.in 2016-10-09 11:27:10.662476565 -0700
+@@ -1,2 +1,2 @@
+ d @runstatedir@/connman - - - -
+-L+ /etc/resolv.conf - - - - @runstatedir@/connman/resolv.conf
++L /etc/resolv.conf - - - - @runstatedir@/connman/resolv.conf
diff --git a/net-misc/connman/files/connman.confd b/net-misc/connman/files/connman.confd
new file mode 100644
index 000000000000..6d0c399e544c
--- /dev/null
+++ b/net-misc/connman/files/connman.confd
@@ -0,0 +1,15 @@
+# conf.d file for connman
+#
+# Please check connmand --help for more information.
+# Useful options are:
+# -c, --compat: enable NetworkManager compatibility mode.
+# -W, --wifi=NAME: select wpa_supplicant wifi driver to use.
+# This is useful if your wpa_supplicant is < 0.7
+# since connmand by default gives wpa_supplicant a
+# comma separated list of values and < 0.7 does not
+# understand or accept it.
+# -i, --device=DEV: force use of given interface name.
+# -I, --nodevice=DEV: force ignore of given interface name.
+# -p, --plugin=NAME: specify plugins to load.
+# -P, --noplugin=NAME: specify plugins not to load.
+CONNMAN_OPTS=""
diff --git a/net-misc/connman/files/connman.initd2 b/net-misc/connman/files/connman.initd2
new file mode 100644
index 000000000000..428245d7f6e2
--- /dev/null
+++ b/net-misc/connman/files/connman.initd2
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Purpose License v2
+
+depend() {
+ need dbus
+ provide net
+}
+
+start() {
+ ebegin "Starting Connection Manager"
+ start-stop-daemon --start --quiet --exec /usr/sbin/connmand -- ${CONNMAN_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Connection Manager"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/connmand
+ eend $?
+}
+
+# vim: set ft=gentoo-init-d ts=3 sw=3 et:
diff --git a/net-misc/connman/files/connman.service b/net-misc/connman/files/connman.service
new file mode 100644
index 000000000000..ece38a716e96
--- /dev/null
+++ b/net-misc/connman/files/connman.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Network Connection Manager Daemon
+
+[Service]
+Type=dbus
+BusName=net.connman
+ExecStart=/usr/sbin/connmand --nodaemon
+
+[Install]
+WantedBy=multi-user.target
+Alias=net.connman.service