summaryrefslogtreecommitdiff
path: root/net-misc/connman-notify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /net-misc/connman-notify
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'net-misc/connman-notify')
-rw-r--r--net-misc/connman-notify/Manifest1
-rw-r--r--net-misc/connman-notify/connman-notify-0_pre20191003-r2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/connman-notify/Manifest b/net-misc/connman-notify/Manifest
index 774005939a05..6b2299e24720 100644
--- a/net-misc/connman-notify/Manifest
+++ b/net-misc/connman-notify/Manifest
@@ -1,3 +1,4 @@
DIST connman-notify-0_pre20191003.tar.bz2 9102 BLAKE2B 7c31de51b21f7cae475b543cf74bba1d969c779f00d1dab7ebce2da6758e1dec6c3c06ae1f0ab133292fc03c1dc61cd1c18c4719311f7a7b65f1771afb097b64 SHA512 6ca8dce104fc5c94af8ef4fab94e44f6a921017d58bbe12660f6bb6a6a0ab6b0808bb7584b75d2acaa486d4cbe718f436fcf7924d6baac97b59a2b77a13215f4
EBUILD connman-notify-0_pre20191003-r1.ebuild 948 BLAKE2B 8b608d6576417ad978e1a1be91340cb8d449c91a591439e8450873907942725297fad523a287d21ad90af1afea08ad6f81d54a1ab6cc3c62bfbc091d20e90561 SHA512 976104fe1ea5e0131717146bcf1890fc935992e6c2823739b62b0bf908b5dc2df34d7e4a8dac5a2676280be09e926895c63cca5957c42faa5b83aa796c44e382
+EBUILD connman-notify-0_pre20191003-r2.ebuild 947 BLAKE2B e35b01aaff21a376caeafe9eb750cccc6594ed80ca06bbac27aa1a447fbb487f722a798b5cfb2dd7f34d568a2bd1d236297f28c0c96d4639b085c57979e850bf SHA512 e49827a6f26fe43145de0acbc0c8985c5b685a8c47c4e21bfd33302c5c6e6d43fb24ecf0ce0c56b765c9f197146af156c9b06340ff779a4e7a356ab55c34f98d
MISC metadata.xml 240 BLAKE2B 5caea4abbcf161615353b1f5ec499ae37ae67f08f6f1d48829d145694359169508d62173c091700e9a65d8ed461216caf12cc6728760784aa364d610250369ca SHA512 ee5c2cad860daff025c5d2bbc7e210767432dd09d1a74fc7b1d5994686d48739b9bfd446bf1ab7b1b92532f82767e722ea3e38d7a502a7a941f6ac5028000ce8
diff --git a/net-misc/connman-notify/connman-notify-0_pre20191003-r2.ebuild b/net-misc/connman-notify/connman-notify-0_pre20191003-r2.ebuild
new file mode 100644
index 000000000000..7111e0e57bbf
--- /dev/null
+++ b/net-misc/connman-notify/connman-notify-0_pre20191003-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit desktop python-single-r1 vcs-snapshot
+
+MY_COMMIT="4f1e0a6b27ebf5d9b7508594188fe0f86c34ec52"
+
+DESCRIPTION="Desktop notification integration for connman"
+HOMEPAGE="https://gitlab.com/wavexx/connman-notify/"
+SRC_URI="https://gitlab.com/wavexx/connman-notify/repository/${MY_COMMIT}/archive.tar.bz2 -> ${P}.tar.bz2"
+
+EGIT_REPO_URI="https://gitlab.com/wavexx/connman-notify.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ net-misc/connman
+ virtual/notification-daemon"
+
+src_install() {
+ python_fix_shebang ${PN}
+ dobin ${PN}
+ dodoc README.rst
+
+ make_desktop_entry ${PN} ${PN} ${PN} Network
+}