summaryrefslogtreecommitdiff
path: root/net-misc/connman-json-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-misc/connman-json-client
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-misc/connman-json-client')
-rw-r--r--net-misc/connman-json-client/Manifest2
-rw-r--r--net-misc/connman-json-client/connman-json-client-1.0_p20150721-r1.ebuild34
-rw-r--r--net-misc/connman-json-client/files/cjc-fix-for-json-0.14.patch33
3 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/connman-json-client/Manifest b/net-misc/connman-json-client/Manifest
index 995df32838ba..c1620f8e7517 100644
--- a/net-misc/connman-json-client/Manifest
+++ b/net-misc/connman-json-client/Manifest
@@ -1,3 +1,5 @@
+AUX cjc-fix-for-json-0.14.patch 1554 BLAKE2B a521777f66e34a425306c03f92096731f8ad93f6001930efabafbc4764ce698110a482063f53dcb0eec34a3ffae871407ef1ff53a6a918a6c809decee9b85cc7 SHA512 6a545259c2ffa4f9c5e628566890264aaf2be908e2a2a3313812777a28e1b57a60f1c8920f88f25a0574fe1a2e101c8dd020b51cb22ae1ebb851cca3b0f3bb50
DIST connman-json-client-1.0_p20150721.tar.gz 55520 BLAKE2B 81f81721563bb8a7c4e604e8a036b162329f1334092f345438c34f787bceb8e548d69e0c206773b880799d1327858275bbbade59d1b84271e4fc05372937ce7a SHA512 77cfbc9f1b57ff5ce73a80f42198bbdb7120db6510f3f33251465ed83d1fac3b2bb41e3959f43cc8d274d37c8da375009a07e9003664482136eed64f5b32c0bc
+EBUILD connman-json-client-1.0_p20150721-r1.ebuild 743 BLAKE2B 595dbdb5c7fd0bad7c1f52f72fd358bc08111f8689c0cf1fb7637f709a14e8c714ab9c836d479a8e9591eddd8c483801c83e4c5af67555c4c22ceb3b3f79e5a7 SHA512 47981ff59de9d818f890829e7303ce4e9264ba9835dc95ac5c3b68bba66a95dc1dbe09e116a2102c4ee4334d067ad8f0aa5fa53ab51fa9380081df9d413b891b
EBUILD connman-json-client-1.0_p20150721.ebuild 688 BLAKE2B 8ff4b658ab133591302bcaad1e0b326e3526e7322538f63350edbf0e94818bad9cfc74f3cda28cebbd50e52775400ed5c026cfc1e3124a7fcbe847f290964d17 SHA512 c7cd3fcf259ad093dc6ce3390ffcce967955207792aaa58f6ada4ea26d1bb3b01abcc0ae126d78b0a28062ff40591eaa36a8f8b6e584986b4ca4dc094ac9527a
MISC metadata.xml 240 BLAKE2B 5caea4abbcf161615353b1f5ec499ae37ae67f08f6f1d48829d145694359169508d62173c091700e9a65d8ed461216caf12cc6728760784aa364d610250369ca SHA512 ee5c2cad860daff025c5d2bbc7e210767432dd09d1a74fc7b1d5994686d48739b9bfd446bf1ab7b1b92532f82767e722ea3e38d7a502a7a941f6ac5028000ce8
diff --git a/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r1.ebuild b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r1.ebuild
new file mode 100644
index 000000000000..71df6bec7998
--- /dev/null
+++ b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+COMMIT="3c34b2ee62d2e188090d20e7ed2fd94bab9c47f2"
+
+DESCRIPTION="An ncurses UI for connman"
+HOMEPAGE="https://github.com/eurogiciel-oss/connman-json-client"
+SRC_URI="https://github.com/eurogiciel-oss/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/json-c:0=
+ >=sys-apps/dbus-1.4
+ sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cjc-fix-for-json-0.14.patch )
+
+src_prepare() {
+ sed -i -e '/^AM_CFLAGS/ s/ -Werror$//' Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dobin connman_ncurses
+}
diff --git a/net-misc/connman-json-client/files/cjc-fix-for-json-0.14.patch b/net-misc/connman-json-client/files/cjc-fix-for-json-0.14.patch
new file mode 100644
index 000000000000..5cc8d55f3247
--- /dev/null
+++ b/net-misc/connman-json-client/files/cjc-fix-for-json-0.14.patch
@@ -0,0 +1,33 @@
+diff -ur a/json_regex.c b/json_regex.c
+--- a/json_regex.c 2020-05-05 07:24:03.294949374 -0500
++++ b/json_regex.c 2020-05-05 07:24:38.883944012 -0500
+@@ -64,7 +64,7 @@
+ json_object_object_add(jregex_agent_response, "Username", json_object_new_string("^([[:print:]]*)$"));
+ json_object_object_add(jregex_agent_response, "Password", json_object_new_string("^([[:print:]]*)$"));
+
+- jregex_agent_retry_response = json_object_new_boolean(TRUE);
++ jregex_agent_retry_response = json_object_new_boolean(1);
+
+ // See commands.c __cmd_config_service for a better idea of the format.
+ jregex_config_service = json_object_new_object();
+@@ -94,7 +94,7 @@
+ json_object_array_add(arr, json_object_new_string("^([[:print:]]*)$"));
+ json_object_object_add(tmp, key_serv_proxy_excludes, arr);
+ json_object_object_add(opt, key_serv_proxy_config, tmp);
+- json_object_object_add(opt, key_serv_autoconnect, json_object_new_boolean(TRUE));
++ json_object_object_add(opt, key_serv_autoconnect, json_object_new_boolean(1));
+ arr = json_object_new_array();
+ json_object_array_add(arr, json_object_new_string("^([[:print:]]*)$"));
+ json_object_object_add(opt, key_serv_domains_config, arr);
+diff -ur a/json_utils.c b/json_utils.c
+--- a/json_utils.c 2020-05-05 07:24:03.294949374 -0500
++++ b/json_utils.c 2020-05-05 07:24:58.877379129 -0500
+@@ -83,7 +83,7 @@
+ key_is_trusted = json_object_object_get_ex(jtrusted, key,
+ &tmp_trusted);
+
+- if (key_is_trusted == FALSE)
++ if (key_is_trusted == 0)
+ return false;
+
+ res = __json_type_dispatch(val, tmp_trusted);