summaryrefslogtreecommitdiff
path: root/net-misc/connect/connect-1.103.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/connect/connect-1.103.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/connect/connect-1.103.ebuild')
-rw-r--r--net-misc/connect/connect-1.103.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/connect/connect-1.103.ebuild b/net-misc/connect/connect-1.103.ebuild
new file mode 100644
index 000000000000..5158dff54002
--- /dev/null
+++ b/net-misc/connect/connect-1.103.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="network connection relaying command (proxy)"
+HOMEPAGE="https://bitbucket.org/gotoh/connect"
+HG_COMMIT_ID="ee1fbc21da4b" # bitbucket commit id
+#SRC_URI="https://www.bitbucket.org/gotoh/connect/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI="https://bitbucket.org/gotoh/connect/get/${HG_COMMIT_ID}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/gotoh-connect-${HG_COMMIT_ID}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "There is no manpage."
+ einfo "Please see https://bitbucket.org/gotoh/connect/wiki/Home for details."
+ einfo
+}