summaryrefslogtreecommitdiff
path: root/net-misc/axel/axel-2.17.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-misc/axel/axel-2.17.10.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-misc/axel/axel-2.17.10.ebuild')
-rw-r--r--net-misc/axel/axel-2.17.10.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/axel/axel-2.17.10.ebuild b/net-misc/axel/axel-2.17.10.ebuild
new file mode 100644
index 000000000000..dad9472d9679
--- /dev/null
+++ b/net-misc/axel/axel-2.17.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl nls ssl"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with Portage, one can configure make.conf with:'
+ einfo
+ einfo 'FETCHCOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+ einfo 'RESUMECOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+}