summaryrefslogtreecommitdiff
path: root/net-misc/autoupnp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 09:31:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 09:31:41 +0000
commit983485e93d76602266889d23c963609073b75e51 (patch)
tree19081a3616b34ff1d8bc5521d767740501b31153 /net-misc/autoupnp
parent3a9a4f8b478ff62e3c752e20305edb2c7d91959f (diff)
gentoo auto-resync : 12:11:2022 - 09:31:40
Diffstat (limited to 'net-misc/autoupnp')
-rw-r--r--net-misc/autoupnp/Manifest5
-rw-r--r--net-misc/autoupnp/autoupnp-0.5.0.ebuild33
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild37
-rw-r--r--net-misc/autoupnp/metadata.xml8
4 files changed, 38 insertions, 45 deletions
diff --git a/net-misc/autoupnp/Manifest b/net-misc/autoupnp/Manifest
index 9844d563f22e..708ce46ee1a1 100644
--- a/net-misc/autoupnp/Manifest
+++ b/net-misc/autoupnp/Manifest
@@ -1,4 +1,5 @@
DIST autoupnp-0.4.7.tar.bz2 264916 BLAKE2B 3542c577a32f5ba3a8ea60c6f2ebb3d5cea76fa440d281e6895c246252d3ba70720aaafa4d843f06a23f1b022942cddb2a0b37b41eff91919db55fbbd87f28b5 SHA512 2c6bb3421fecbffea2a63ea1e930b7c789459d4626a0f281abe0e9bb62e5efc772475d4bf0c9f13fe2e9e13417940c6eb17408e6aae28bc24a4fc2e16d4dc8de
+DIST autoupnp-0.5.0.tar.gz 7402 BLAKE2B b6de76a45e6811e57cfb15bf41d3305ad4e8ed9b1459270426724b016d33a9a398bae5bca4d3d87360d712614fcad0fa5d8571db88ce632afd43220539ba992d SHA512 0118b20fdb225673348c3ba469bfde6c37e79fba42e7dbf7bca6a0c25dd9f853b0ee73860c5dbb8165e97125cb71b2794d4e88ece0a1155c85f4c83390131dbc
EBUILD autoupnp-0.4.7.ebuild 613 BLAKE2B c27ef2e0ceca01d708ca3613289f57f00adcabc20a34105c1a157db81dc982594d00142ea55dd8efc108ce7b8b3bc45950c923bfe5dcdbf990ac213bb9b61ca1 SHA512 a10502a183a05be67b128714c3a0e0acb5773c7b9e776093857575b5197812f1569a31ccc6ff45142798b4a4f66435c9d5a086b7e49e25dd9de6f54042f54e91
-EBUILD autoupnp-9999.ebuild 638 BLAKE2B c0d9468b76db496100c6f2897c716361af2604cd11b70c12d5d4676f97f478bbdee86f4b9d7347323a1585b2c27f84988fe2d489804df47b14db4a421565cf7a SHA512 e306e4285009481c31399d5217aa9549cfafdebd9952fa73802b399b560bc3688b02575d904f759e3c377c8abcd866f46b71dde0a6bb294b74526b04ddd3611f
-MISC metadata.xml 506 BLAKE2B c4f57634d98b30ba532903b86576bf08f4a24c86b0b00c02976753e2c70447f69802fe750c9892557bcbdbb14ab79b6f26bd45a037fbde799215b4734a9985a0 SHA512 f0dacc0b507514389e473f83e6d3f9e6198be0dd077838b57100efabec97c8647e6ef8c000c3ac9e6606cace0a4601e9939ef0d9e2fe61366eaebce6e24059af
+EBUILD autoupnp-0.5.0.ebuild 575 BLAKE2B fa4085e87095e89f62de9c7521540aaedeb421cdf3f79b40b63665fbe10dbe900d8332677da39c244c48e8f6c0428efa810ac000275e9a471534808cbca86be2 SHA512 e524f8bf4c81f5534d555c3dc6a77ca33a7ab0252af3b603fd38321d0033a0a67e8515a71696ac0b75016c36c6ae813b50cbc7c064b37a7adf30bf6b1999fe51
+MISC metadata.xml 392 BLAKE2B d4e689854968e0f26c88b8fa7f615df0d996711233e46bb0bdf1b265b31fa13a614b05a2e03b6b9df101b536dfea70f067a97661bba05bf7624e933a3ee7637d SHA512 42b53800c487b2e53644467ad0f754112d9116179d000dece34c824d1ab2a992046e1048139d88bc2202b5974e14ace9896af9500f05473ea9ba61dce42fb880
diff --git a/net-misc/autoupnp/autoupnp-0.5.0.ebuild b/net-misc/autoupnp/autoupnp-0.5.0.ebuild
new file mode 100644
index 000000000000..9f5acac5c152
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://github.com/projg2/autoupnp/"
+SRC_URI="
+ https://github.com/projg2/autoupnp/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libnotify)
+ )
+ meson_src_configure
+}
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
deleted file mode 100644
index f7ea428391ea..000000000000
--- a/net-misc/autoupnp/autoupnp-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools git-r3
-
-DESCRIPTION="Automatic open port forwarder using UPnP"
-HOMEPAGE="https://github.com/mgorny/autoupnp/"
-EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="libnotify"
-
-RDEPEND="net-libs/miniupnpc:0=
- libnotify? ( x11-libs/libtinynotify:0= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_with libnotify)
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/net-misc/autoupnp/metadata.xml b/net-misc/autoupnp/metadata.xml
index 2b97f05c8032..ff2e8e5125ef 100644
--- a/net-misc/autoupnp/metadata.xml
+++ b/net-misc/autoupnp/metadata.xml
@@ -6,11 +6,7 @@
<name>Michał Górny</name>
</maintainer>
<upstream>
- <maintainer status="active">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <bugs-to>https://github.com/mgorny/autoupnp/issues/</bugs-to>
- <remote-id type="github">mgorny/autoupnp</remote-id>
+ <bugs-to>https://github.com/projg2/autoupnp/issues/</bugs-to>
+ <remote-id type="github">projg2/autoupnp</remote-id>
</upstream>
</pkgmetadata>