summaryrefslogtreecommitdiff
path: root/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
commitda491770b9ba5f179e18db461c49cb6f1ccf0e1f (patch)
treed3e34a8bd906741ab18cf69d8d4f732853e26ade /net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild
parentad6182343997a405079870a2fe91c4e0c6b94595 (diff)
parent5a165c60b9b8c4847067cb83b4be7da785d01f93 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild')
-rw-r--r--net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild b/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild
new file mode 100644
index 000000000000..4ec2a9e70bcc
--- /dev/null
+++ b/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.4.11-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Extra sounds for asterisk"
+HOMEPAGE="http://www.asterisk.org/"
+MY_L10N=(^en fr) # ^ is used to indicate to the loops below to NOT set this as an optional
+CODECS=(alaw g722 g729 +gsm siren7 siren14 sln16 ulaw wav)
+
+SRC_URI=""
+IUSE="${CODECS[*]}"
+REQUIRED_USE="|| ( ${CODECS[*]#+} )"
+for l in "${MY_L10N[@]}"; do
+ [[ ${l} != ^* ]] && IUSE+=" l10n_${l}" && SRC_URI+=" l10n_${l}? ("
+ for c in "${CODECS[@]}"; do
+ SRC_URI+=" ${c#+}? ( http://downloads.asterisk.org/pub/telephony/sounds/releases/${PN}-${l#^}-${c#+}-${PV}.tar.gz )"
+ done
+ [[ ${l} == ^* ]] || SRC_URI+=" )"
+done
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=net-misc/asterisk-1.4"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local ar
+ for ar in ${A}; do
+ local l="${ar#${PN}-}"
+ l=${l%%-*}
+ mkdir -p "${WORKDIR}/${l}" || die
+ cd "${WORKDIR}/${l}" || die
+ unpack "${ar}"
+ done
+}
+
+src_install() {
+ local l
+ for l in "${MY_L10N[@]}"; do
+ if [[ ${l} == ^* ]] || use "l10n_${l}"; then
+ l="${l#^}"
+ dodoc "${l}/CHANGES-${PN%-sounds}-${l}-${PV}" \
+ "${l}/${PN#asterisk-}-${l}.txt"
+ rm "${l}/CHANGES-${PN%-sounds}-${l}-${PV}" \
+ "${l}/${PN#asterisk-}-${l}.txt" || die
+ fi
+ done
+
+ diropts -m 0770 -o asterisk -g asterisk
+ insopts -m 0660 -o asterisk -g asterisk
+ insinto /var/lib/asterisk/sounds
+ doins -r .
+}