summaryrefslogtreecommitdiff
path: root/net-misc/AQtion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-misc/AQtion
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-misc/AQtion')
-rw-r--r--net-misc/AQtion/AQtion-2.3.1.ebuild53
-rw-r--r--net-misc/AQtion/Manifest2
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/AQtion/AQtion-2.3.1.ebuild b/net-misc/AQtion/AQtion-2.3.1.ebuild
new file mode 100644
index 000000000000..6ea5a134c5c6
--- /dev/null
+++ b/net-misc/AQtion/AQtion-2.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+DESCRIPTION="Aquantia AQC multigigabit NIC linux driver (atlantic) - development preview"
+HOMEPAGE="https://github.com/Aquantia/AQtion"
+
+COMMIT_ID="3c2a2a3abe3df6cb0c985a49cea9a359a83e3f75"
+SRC_URI="https://github.com/Aquantia/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lro"
+
+DEPEND="virtual/linux-sources"
+
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+MODULE_NAMES="atlantic(drivers/net/ethernet/aquantia/atlantic:${S})"
+BUILD_TARGETS="all"
+CONFIG_CHECK="~!AQTION ~PTP_1588_CLOCK ~CRC_ITU_T"
+
+DOCS=(
+ README.md
+ README.txt
+)
+
+pkg_setup() {
+ use lro && CONFIG_CHECK+=" ~!CONFIG_BRIDGE"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use lro; then
+ sed -r -i -e 's/(#define AQ_CFG_IS_LRO_DEF[[:space:]]+)[[:digit:]]+([[:alpha:]]*)/\10\2/' \
+ aq_cfg.h || die
+ fi
+}
+
+src_compile() {
+ KDIR="${KERNEL_DIR}" linux-mod_src_compile
+}
+
+src_install() {
+ KDIR="${KERNEL_DIR}" linux-mod_src_install
+ dodoc "${DOCS[@]}"
+}
diff --git a/net-misc/AQtion/Manifest b/net-misc/AQtion/Manifest
index 2cd0f5efc12d..2983f65e6219 100644
--- a/net-misc/AQtion/Manifest
+++ b/net-misc/AQtion/Manifest
@@ -1,3 +1,5 @@
DIST AQtion-2.2.7.tar.gz 122679 BLAKE2B 9d4e2d4d4b26a191551e2cfd30c2a8ce4e4bde01b7ab1e9beb9564abdfd1093b63f94713570fe2c949943037b649c55a9f448b0333fcdcc7227849330d466f92 SHA512 d3ba78acbe5d85d1017d5460fa7d916ffa59eeb137aa1817da215f08b994a10336a9f865c9b84a16b8cef7238d4fd87785bc17d6e3eac577210bf321538cbda3
+DIST AQtion-2.3.1.tar.gz 122884 BLAKE2B 46037acfdb3914eb2aac26795d923f22e34bf51ed31c993169803ea572108fe0bf98ef61bbadfa86b7027161aa5105c8b2cb4f19e1b12388ce9296f87f2f7c6d SHA512 929a4f208c041340d684e7732256511d68dac71d5204c34c8f0d6aa5832b0de0667bda7e1fa44a5486c7c34692f73c5de397655b0ba0efb12de8d4d76316e835
EBUILD AQtion-2.2.7.ebuild 1095 BLAKE2B 5fe62a9a9e1508adf34a4bb92e058c683daaec15e8663794157eb6ec5edb9358ed6ed909ce169d1538c45e149eaf36a7058ef20af259ac37fa0dc58efa95fe3c SHA512 44dcdc56acca18786bba37c66b718a225799249e1215e8c8803c2036bca3dfa23b9d79cd378bb82ae0879d9bdba915f9bcd126a8562a66ec067a32ed0d72b5b5
+EBUILD AQtion-2.3.1.ebuild 1095 BLAKE2B 31394903271e75f6b7fc834028f5d1a291022ec75ba545a86de60aeacbc7b2a87083103a34d1058b0a63dc1ac7e9d2c54c66ba55e8b032cad927ce115cf9cd66 SHA512 90ca880130f664e09a32aed1f90a2064c96b224cfbf33ca063985bdf36d62355c965b928f8f0250f05972ced30c906c69e02092a75e77eea4146f72bb0b04064
MISC metadata.xml 697 BLAKE2B 2462c0dedde087805f1879750ad183a9c5d29dbd8561270f9e999bda47946517ce45ab70d29851aec06b5f2e79aa93fa5f7d9f09bcb3f089bf4cada541c4b87a SHA512 f2cbb250acd2690842dbdb5645f04e071f08a65e9dd80153fef3fe1c5d35ea1b5c40e8c58309b9323ca53941e902069c11b710037289923ff2b9a77570cb8313