summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /net-mail
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/Manifest.gzbin18241 -> 18237 bytes
-rw-r--r--net-mail/mailbase/Manifest1
-rw-r--r--net-mail/mailbase/mailbase-1.5.ebuild67
3 files changed, 68 insertions, 0 deletions
diff --git a/net-mail/Manifest.gz b/net-mail/Manifest.gz
index 43710fbd57fd..6ffb995683f7 100644
--- a/net-mail/Manifest.gz
+++ b/net-mail/Manifest.gz
Binary files differ
diff --git a/net-mail/mailbase/Manifest b/net-mail/mailbase/Manifest
index bba9c7605a11..98acd563619c 100644
--- a/net-mail/mailbase/Manifest
+++ b/net-mail/mailbase/Manifest
@@ -6,4 +6,5 @@ AUX mailcap.5 9886 BLAKE2B a03170a94f30cda347c97909de7c066efbe2cc7295badd8f8c97a
EBUILD mailbase-1.1.ebuild 1657 BLAKE2B ae93c9819b1e5bb8f8ede43955453d2f6aa68a306ebce97b611bb1b37abcbb12fe390c20a4db2c997f860c0b2b0db251052b12d6073e70c3ee1e40b7361139b5 SHA512 998ad423d34728fd24d0ff04d014568eba456775deedb1551e9c8e05a5993235347b0235975599e330e0545a84d8857ac84ce160fedc3bbb8d8062b908026932
EBUILD mailbase-1.3.ebuild 1458 BLAKE2B 835a54fe1e299fd10342d6d890ef3436b91483a9e12cfc74d4291939c0a8bb1702f9467b9b9f0687a748915fdc3bdccefedaace530d96cb4d37108a474db3e7a SHA512 60cbbe72959a4b0f7f05080765257cdc18bde09c5444acf97d19b4bfbbe70eec3b6e110cbefc382db74d1506f551d9d5e919e8b927465c70fd6ac8a951eaaeb3
EBUILD mailbase-1.4.ebuild 1482 BLAKE2B eb1a131d41e204bc07a0d6a339bbed18c0abd27054a31f259d7ccecc9d129ba3f2c49984b51939ab8e0ee70c7d21e7bbd5e8e249f5361ad467b53ec2fd177723 SHA512 9463c5dd2bdc408972c4e3fd4a926f97a7e36672d2f6fcca5e361dd922968bea1517bc191bf0dc968fcda51cfcb3951ef1def837a88fc38bc680ae2b1746f0a9
+EBUILD mailbase-1.5.ebuild 1482 BLAKE2B 4862a2824fb0c7f56ca4a0c7c443c0dfeb46824bd82fe144233efa397173d8620ba53d8ee9ba97d92bd7d368b694fec8645cd37d5216b6f707286595a35229d2 SHA512 001c7732c000d60fa3c336a1b57dc973c650814b6dba511d520d1977d67e9dc1f938d6d7c186109c8dd2f0dbe39bb541ab4a41ddc1e435e85ec88ef883ce1a46
MISC metadata.xml 240 BLAKE2B eeb6099e7ebc29b81588528b970830d2461fa16783bda673672d405615e46d240dcd806b3d18b6207ef8e5365f8860aa20c304394c3f5b267c5ea4dc739cb94b SHA512 97824dbce22630efb21e647b55212b7a8a19d8e38b5bf05cb0b8078530bbbaaf4dc91284e2a11beab7dfcfb779df82b87b49d11a746c7a4f6dc71f2fda8942db
diff --git a/net-mail/mailbase/mailbase-1.5.ebuild b/net-mail/mailbase/mailbase-1.5.ebuild
new file mode 100644
index 000000000000..898d804dc88a
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit pam user
+
+DESCRIPTION="MTA layout package"
+SRC_URI=""
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="pam"
+
+RDEPEND="pam? ( virtual/pam )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup mail 12
+ enewuser mail 8 -1 /var/spool/mail mail
+ enewuser postmaster 14 -1 /var/spool/mail
+}
+
+src_install() {
+ dodir /etc/mail
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases
+ insinto /etc
+ doins "${FILESDIR}"/mailcap
+ doman "${FILESDIR}"/mailcap.5
+
+ keepdir /var/spool/mail
+ fowners root:mail /var/spool/mail
+ fperms 03775 /var/spool/mail
+ dosym spool/mail /var/mail
+
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ if use pam ; then
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p}
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p}
+ done
+ fi
+}
+
+get_permissions_oct() {
+ if [[ ${USERLAND} = GNU ]] ; then
+ stat -c%a "${ROOT}$1"
+ elif [[ ${USERLAND} = BSD ]] ; then
+ stat -f%p "${ROOT}$1" | cut -c 3-
+ fi
+}
+
+pkg_postinst() {
+ # bug 614396
+ if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
+ einfo "Fixing ${ROOT}/var/spool/mail/ permissions"
+ chown root:mail "${ROOT}/var/spool/mail/"
+ chmod 03775 "${ROOT}/var/spool/mail/"
+ fi
+}