summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 17:14:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 17:14:47 +0000
commit25e5a6599437664a3eff8d9f8a966adc896e09e8 (patch)
tree67ef90a99446e1fee47c4ebb4c8c3a8175b41913 /net-mail
parent24b2471760a35870c85ca752666bcb66120289af (diff)
gentoo auto-resync : 11:12:2023 - 17:14:47
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/Manifest.gzbin14374 -> 14379 bytes
-rw-r--r--net-mail/asmail/Manifest2
-rw-r--r--net-mail/asmail/asmail-2.1-r3.ebuild57
-rw-r--r--net-mail/asmail/files/asmail-2.1-update-autotools.patch61
4 files changed, 120 insertions, 0 deletions
diff --git a/net-mail/Manifest.gz b/net-mail/Manifest.gz
index 8a8a9a6241e8..31d333cd18a7 100644
--- a/net-mail/Manifest.gz
+++ b/net-mail/Manifest.gz
Binary files differ
diff --git a/net-mail/asmail/Manifest b/net-mail/asmail/Manifest
index 3054818f6433..2a76e03ba3cb 100644
--- a/net-mail/asmail/Manifest
+++ b/net-mail/asmail/Manifest
@@ -1,4 +1,6 @@
AUX asmail-2.1-ldflags.patch 584 BLAKE2B 58b53fadf6209149a74c65333d742f99c549abab08b87e577e7363ff3a2601dd0e78a9d23181676510d6194e9533eb6293c45c089ccb4dcd85955e7aaf0a6c93 SHA512 d3714a3b250b434cd742c6a72afd73c673194375240c2d3ab3f61999be6c36f07dee9ed8cb86220b559613a10a00431757ad95121aba16196ecbc719eb347dc9
+AUX asmail-2.1-update-autotools.patch 1782 BLAKE2B 1f9c9fee8fc1f30a1f401a25fa9babbb7252831b2ceea9bf3967c40c476871832fdb707159458a4d2ffd4c7319dc5b38e058305d2d3aeff7af07f24e497972c9 SHA512 c1ac1b7ce741635347da88d2015bda11f5ff3c5f909702e08161d2c850c5b2d1db8f4bb09253b0e15331c57f073060a16d9bdfc318ba28e723e93b71553e84e9
DIST asmail-2.1.tar.gz 271164 BLAKE2B 00972dcdfd74c717a665425cad17c59b01ec631725b79ccc3ed537232e61c5aef231ec4146491335caf2beb451e686359cb196d01f199c33ed16cd66c625e99f SHA512 1251c9f386c01c23673a6798eafd6a518a103da6d2ab78bb4e22c1107939423c44f555e331f79d1b5b509f271582de285481022ef32375b4267b1f3e398f67d8
EBUILD asmail-2.1-r2.ebuild 993 BLAKE2B 4408be4ea04ae78097956ddcf83dd8b743253ee6a3bf816919e737737af1907b97e8446ecfadf82ff359f8681939a91aa9df7cc5375106f35cbca2a6e724b743 SHA512 1e00cc6716f4bc0878e63057e1e4ec017f5137535f7da434e7e3b3a3eadda88eb73f7ab0c12f83b3ea10ce86c575d6f7c8a64dd233bd0a4869b480858798343e
+EBUILD asmail-2.1-r3.ebuild 1085 BLAKE2B 9fe6b11855ada4d6087f1e5051e26e45b4fd3a458c3fffbb29ee23b39479536faf8bb4a89770844d42c98c24a4558d7ece24a0324805cbf12d40034e64b2480e SHA512 a5b8d7897ab8551eda2899da96f784cd1d0e48ba2a4e4cd68ff04caf2b5ca5f2326267ffb153ab4ce2989b3117460784e1c0774543ea97b101dbbf81ebf1cd44
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-mail/asmail/asmail-2.1-r3.ebuild b/net-mail/asmail/asmail-2.1-r3.ebuild
new file mode 100644
index 000000000000..29c8a3a37716
--- /dev/null
+++ b/net-mail/asmail/asmail-2.1-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A small mail monitor similar to xbiff"
+HOMEPAGE="https://tigr.net/afterstep/applets/"
+SRC_URI="https://tigr.net/afterstep/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jpeg"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-libs/libSM
+ jpeg? ( media-libs/libjpeg-turbo:0 )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-update-autotools.patch
+)
+
+src_prepare() {
+ default
+ cd "${S}/autoconf" || die
+ eautoreconf
+ cp "${S}/autoconf/configure" "${S}/" || die
+}
+
+src_configure() {
+ tc-export CC
+ econf $(use_enable jpeg) --with-xpm-library=/usr/$(get_libdir)
+}
+
+src_install() {
+ dobin ${PN}
+
+ newman ${PN}.man ${PN}.1
+ newman ${PN}rc.man ${PN}rc.5
+
+ insinto /usr/share/${PN}/pixmaps
+ doins pixmaps/cloud-e/*.xpm
+
+ insinto /usr/share/${PN}
+ doins -r sounds
+
+ dodoc ${PN}rc.s* CHANGES *.txt README* TODO
+}
diff --git a/net-mail/asmail/files/asmail-2.1-update-autotools.patch b/net-mail/asmail/files/asmail-2.1-update-autotools.patch
new file mode 100644
index 000000000000..287b36480111
--- /dev/null
+++ b/net-mail/asmail/files/asmail-2.1-update-autotools.patch
@@ -0,0 +1,61 @@
+I order to compile this package with clang we need to run autoreconf. Newer autotools complain about
+the several declarations of the same header.
+
+MD5 calculation is split from libssl into libcrypto.
+
+Bug: https://bugs.gentoo.org/880913
+Bug: https://bugs.gentoo.org/900170
+
+--- a/autoconf/Makefile.defines.in
++++ b/autoconf/Makefile.defines.in
+@@ -38,7 +38,8 @@ LIBS_XEXTS =
+ LIBS_AFTERSTEP = -lXt
+ LIBS_PTHREAD = -lpthread -lrt
+ LIBS_SSL = @HAVESSL@
+-LIBRARIES = $(LIBS_X) $(LIBS_XPM) $(LIBS_XEXTS) $(LIBS_PTHREAD) $(LIBS_SSL)
++LIBS_CRYPTO = @HAVECRYPTO@
++LIBRARIES = $(LIBS_X) $(LIBS_XPM) $(LIBS_XEXTS) $(LIBS_PTHREAD) $(LIBS_SSL) $(LIBS_CRYPTO)
+
+ AFTER_BIN_DIR = @bindir@
+ AFTER_MAN_DIR = @mandir@/man1
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -1,3 +1,4 @@
++
+ dnl# -*- sh -*-
+ dnl# Process this file with autoconf to produce a configure script.
+ dnl#
+@@ -61,7 +62,6 @@ AC_CHECK_HEADERS(sys/statvfs.h sys/vfs.h sys/mount.h ustat.h)
+ AC_CHECK_HEADERS(machine/soundcard.h linux/soundcard.h linux/radio.h)
+ AC_CHECK_HEADERS(pthread.h)
+ AC_CHECK_HEADERS(openssl/ssl.h)
+-AC_CONFIG_HEADER(config.h)
+
+ dnl# Check for X
+
+@@ -110,8 +110,12 @@ AC_CHECK_LIB(ssl, SSL_CTX_new, [SSL_LIB="-lssl" HAVESSL="-lssl"],,)
+ MD5_OBJ=""
+ if test "x$HAVESSL" = "x"; then
+ MD5_OBJ="md5c.o"
++else
++ AC_CHECK_HEADERS(openssl/md5.h)
+ fi
+
++AC_CHECK_LIB(crypto, MD5, [CRYPTO_LIB="-lcrypto" HAVECRYPTO="-lcrypto"],,)
++
+ dnl# Variable strings declaration
+
+ AC_SUBST(version)
+@@ -129,11 +133,10 @@ AC_SUBST(with_gnustep_lib)
+ AC_SUBST(with_afterdir)
+ AC_SUBST(HAVESSL)
+ AC_SUBST(MD5_OBJ)
++AC_SUBST(HAVECRYPTO)
+
+ dnl# Write results
+
+-AC_CONFIG_HEADER(config.h)
+-
+ dnl# Common parts of the Makefile
+ MAKEFILEDEFINES=./autoconf/Makefile.defines
+ MAKEFILECOMMON=./autoconf/Makefile.common