summaryrefslogtreecommitdiff
path: root/net-mail/vchkuser/vchkuser-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/vchkuser/vchkuser-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/vchkuser/vchkuser-0.4.ebuild')
-rw-r--r--net-mail/vchkuser/vchkuser-0.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-mail/vchkuser/vchkuser-0.4.ebuild b/net-mail/vchkuser/vchkuser-0.4.ebuild
new file mode 100644
index 000000000000..f007e274eaec
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="https://github.com/hollow/vchkuser"
+SRC_URI="https://github.com/hollow/vchkuser/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="net-mail/vpopmail
+ || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
+RDEPEND=""
+
+S="${WORKDIR}/hollow-${PN}-8a048f7"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir=/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ fowners vpopmail:nofiles "${QMAIL_HOME}"/plugins/vchkuser
+ fperms 4750 "${QMAIL_HOME}"/plugins/vchkuser
+}