summaryrefslogtreecommitdiff
path: root/net-mail/vacation/vacation-1.2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/vacation/vacation-1.2.7.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/vacation/vacation-1.2.7.0.ebuild')
-rw-r--r--net-mail/vacation/vacation-1.2.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-mail/vacation/vacation-1.2.7.0.ebuild b/net-mail/vacation/vacation-1.2.7.0.ebuild
new file mode 100644
index 000000000000..2eaf3b4e99a2
--- /dev/null
+++ b/net-mail/vacation/vacation-1.2.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="automatic mail answering program"
+HOMEPAGE="http://vacation.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vacation/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/mta
+ sys-libs/gdbm"
+DEPEND="${RDEPEND}
+ !mail-mta/sendmail"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:install -s -m:install -m:" Makefile
+ sed -i -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile
+}
+
+src_compile () {
+ emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
+ "make install failed"
+}