summaryrefslogtreecommitdiff
path: root/net-mail/smtptools/smtptools-0.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /net-mail/smtptools/smtptools-0.2.3-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'net-mail/smtptools/smtptools-0.2.3-r1.ebuild')
-rw-r--r--net-mail/smtptools/smtptools-0.2.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/smtptools/smtptools-0.2.3-r1.ebuild b/net-mail/smtptools/smtptools-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..4c93c7172b36
--- /dev/null
+++ b/net-mail/smtptools/smtptools-0.2.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A collection of tools to send or receive mails with SMTP"
+HOMEPAGE="https://www.ohse.de/uwe/software/smtptools.html"
+SRC_URI="ftp://ftp.ohse.de/uwe/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+RDEPEND="!net-mail/qtools"
+PATCHES=(
+ "${FILESDIR}"/${P}-cleanups.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-autotools.patch
+ mv configure.{in,ac} || die
+ rm acconfig.h || die
+
+ default
+ eautoreconf
+}