summaryrefslogtreecommitdiff
path: root/net-mail/ripole/ripole-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/ripole/ripole-0.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/ripole/ripole-0.2.2.ebuild')
-rw-r--r--net-mail/ripole/ripole-0.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/ripole/ripole-0.2.2.ebuild b/net-mail/ripole/ripole-0.2.2.ebuild
new file mode 100644
index 000000000000..b2830570efa9
--- /dev/null
+++ b/net-mail/ripole/ripole-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program/library to pull out attachment from OLE2 data files"
+HOMEPAGE="http://www.pldaniels.com/ripole/"
+SRC_URI="http://www.pldaniels.com/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-ldflags.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ripole
+ dodoc CHANGELOG README CONTRIBUTORS
+}