summaryrefslogtreecommitdiff
path: root/net-mail/ripole/ripole-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /net-mail/ripole/ripole-0.2.1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'net-mail/ripole/ripole-0.2.1.ebuild')
-rw-r--r--net-mail/ripole/ripole-0.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/ripole/ripole-0.2.1.ebuild b/net-mail/ripole/ripole-0.2.1.ebuild
new file mode 100644
index 000000000000..5e8fab2f787b
--- /dev/null
+++ b/net-mail/ripole/ripole-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program/library to pull out attachment from OLE2 data files"
+HOMEPAGE="http://www.pldaniels.com/ripole/"
+SRC_URI="http://www.pldaniels.com/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 hppa ~sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-ldflags.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ripole
+ dodoc CHANGELOG README CONTRIBUTORS
+}