summaryrefslogtreecommitdiff
path: root/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild')
-rw-r--r--net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild b/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..a67868c14c27
--- /dev/null
+++ b/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+DESCRIPTION="A toolkit for dealing with the qmail queue directory structure"
+HOMEPAGE="http://pyropus.ca/software/queue-repair/"
+SRC_URI="http://pyropus.ca/software/queue-repair/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test" # no tests
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS=( BLURB TODO CHANGELOG )
+
+src_prepare() {
+ eapply_user
+
+ 2to3 -n -w --no-diffs queue_repair.py || die
+}
+
+src_install() {
+ python_newscript queue_repair.py queue-repair.py
+ dosym queue-repair.py /usr/bin/queue-repair
+ einstalldocs
+}