summaryrefslogtreecommitdiff
path: root/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild')
-rw-r--r--net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild b/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..ecb94ffdd881
--- /dev/null
+++ b/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A toolkit for dealing with the qmail queue directory structure"
+HOMEPAGE="http://pyropus.ca/software/queue-repair/"
+SRC_URI="http://pyropus.ca/software/queue-repair/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS=( BLURB TODO CHANGELOG )
+
+src_install () {
+ python_newscript queue_repair.py queue-repair.py
+ dosym /usr/bin/queue-repair.py /usr/bin/queue-repair
+ einstalldocs
+}