summaryrefslogtreecommitdiff
path: root/net-mail/qmhandle/qmhandle-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/qmhandle/qmhandle-1.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/qmhandle/qmhandle-1.3.2.ebuild')
-rw-r--r--net-mail/qmhandle/qmhandle-1.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mail/qmhandle/qmhandle-1.3.2.ebuild b/net-mail/qmhandle/qmhandle-1.3.2.ebuild
new file mode 100644
index 000000000000..2bf3394612cb
--- /dev/null
+++ b/net-mail/qmhandle/qmhandle-1.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Qmail message queue tool"
+HOMEPAGE="http://qmhandle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qmhandle/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="virtual/qmail
+ dev-lang/perl
+ sys-process/psmisc
+"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed \
+ -e 's|/usr/local/bin/svc|/usr/bin/svc|g' \
+ -e 's|/service/qmail-deliver|/var/qmail/supervise/qmail-send|g' \
+ -i qmHandle
+}
+
+src_install() {
+ dodoc README HISTORY
+ dobin qmHandle || die "dobin failed"
+}