summaryrefslogtreecommitdiff
path: root/net-mail/public-inbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-mail/public-inbox
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-mail/public-inbox')
-rw-r--r--net-mail/public-inbox/Manifest3
-rw-r--r--net-mail/public-inbox/metadata.xml12
-rw-r--r--net-mail/public-inbox/public-inbox-1.7.0.ebuild38
3 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/public-inbox/Manifest b/net-mail/public-inbox/Manifest
new file mode 100644
index 000000000000..9258707a76dc
--- /dev/null
+++ b/net-mail/public-inbox/Manifest
@@ -0,0 +1,3 @@
+DIST public-inbox-1.7.0.tar.gz 805628 BLAKE2B 4403cd11a2c4f793b136aff07ccc06ea60011c21484196e497921ca36599870eecdf7b93f550ef44e876bca814a3b03e1d8d4b484113506ee809098124cfd1b2 SHA512 cb03d2ec3e28f1fc75bdbff2b8ea5b417898ddb2895d27b105624cab35f0dcab99269d86bfc158bdf42faecb7b7a5734363a81d2202970e8d079bf05fa359250
+EBUILD public-inbox-1.7.0.ebuild 823 BLAKE2B 3d98c16723c2c50e3fd795455db11893fe594254d7cc832adc139d76d76b19b0e055ae2b260936b6512bf1c8f1548b818b26cc3f5649a2e1bc08ae4fa94713f1 SHA512 16535edc771c53ed10b90cb6aa4f400c8ae38f7d4080bdfb5a6600d9b90ec2016cffe5af64f6d36b8ffe28d6913c4d19105ddad0a7bc7953fad76e944d324988
+MISC metadata.xml 378 BLAKE2B 569717fcbe03797e4b5dd1fa859bddbb5947d1f4e51687c05ec955d23d85ba3c1b2cac0eaaa5221800e7db719c5106b1e2f3e9ba3e9594eff649ff2642b154bb SHA512 d5c104ddf9fbd660f6e57e6fb2543c0b5a166f6fc32a7f719a749641ba1a154781ee3745759ad649cba02815607b238b8a85f68580a3830d6d59f143f1dcce0c
diff --git a/net-mail/public-inbox/metadata.xml b/net-mail/public-inbox/metadata.xml
new file mode 100644
index 000000000000..3d9412e88943
--- /dev/null
+++ b/net-mail/public-inbox/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-mail/public-inbox/public-inbox-1.7.0.ebuild b/net-mail/public-inbox/public-inbox-1.7.0.ebuild
new file mode 100644
index 000000000000..6d7bfd810fcf
--- /dev/null
+++ b/net-mail/public-inbox/public-inbox-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+HOMEPAGE="https://public-inbox.org"
+SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
+DESCRIPTION="An archives-first approach to mailing lists"
+LICENSE="AGPL-3+"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# in order of mention in INSTALL.html, going more for feature completeness
+# than for minimal footprint
+RDEPEND="
+ dev-vcs/git
+ dev-perl/DBD-SQLite
+ virtual/mta
+ dev-perl/URI
+ dev-perl/Plack
+ dev-perl/TimeDate
+ dev-perl/Inline-C
+ dev-perl/Email-Address-XS
+ dev-perl/Search-Xapian
+ dev-perl/Parse-RecDescent
+ dev-perl/Mail-IMAPClient
+ dev-perl/BSD-Resource
+ net-misc/curl
+ dev-perl/Linux-Inotify2
+ dev-perl/Net-Server
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"