summaryrefslogtreecommitdiff
path: root/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild')
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild
new file mode 100644
index 000000000000..dc661eb713af
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://michael.orlitzky.com/code/postfix-logwatch.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}