summaryrefslogtreecommitdiff
path: root/net-mail/poppassd_ceti
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /net-mail/poppassd_ceti
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'net-mail/poppassd_ceti')
-rw-r--r--net-mail/poppassd_ceti/Manifest2
-rw-r--r--net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-mail/poppassd_ceti/Manifest b/net-mail/poppassd_ceti/Manifest
index b89e7eaea379..208ee9f17036 100644
--- a/net-mail/poppassd_ceti/Manifest
+++ b/net-mail/poppassd_ceti/Manifest
@@ -1,4 +1,6 @@
AUX poppassd.xinetd 245 BLAKE2B 28fe0bc0c1c87c4ff48cae52c703a4a6c3e776bf91b869040025951dbaf1f07345a95c9bc45d40f87c3ad9a83d6556421f805d65952f4f9d7588abed9bb5b25f SHA512 333d331433a0b43f414f83e51cad3502afb6f5b287967e55d0dedd90ac06955ccbcbe598a3dafe682c97a7ac4ecf501c0842ade940c0702fb797717e8844ffd4
DIST poppassd-ceti-1.8.7.tar.xz 71400 BLAKE2B ca26f7298a8f679c595a9cd66622f1e8ddeff80a7b1655df91a7a15668337112113806d0aef788a374c483cbc957e765b178428d839da2c853ebf87e16039548 SHA512 d50549a4f6bdd9eac7fa74a7787e47dbffff14da883d4e8e23e24802883761c1a392b8a7fbffe5fa726845f48b3b33e0dbc1743ad2d689a4d396c91d0a42f8f1
+DIST poppassd-ceti-1.8.9.tar.gz 15465 BLAKE2B 22f6b521d83c4b7c4a8842cde22710c17dda26f9cbfb39d020de05b14c045a1606fcebf51557c2e38c932e009554c5f0d1f770d5cfbf1666f81eb03a342c25f4 SHA512 cc8953aaed8cd6d2633d1c2040e364770598eb71d563a29fd3f4798730654d002ba720babab0596cc336ea8aff403064e17e8b17c3df657e5c840db2230a2077
EBUILD poppassd_ceti-1.8.7.ebuild 1678 BLAKE2B bb77369d9c5ed2ec923a00c5813a16d6c55f92e429d16011d20398ee95f6999137ad3e9f4b43f72d927ec85faf3dcb58cef203e9d4cc4f5f63bc1ba6b4ca788a SHA512 93fc50a9205e0a543e2d9d729b6450a3b736079a83061fd912e491c2d5dd1149658ec2d8d4349ccea6f183f40837b143a724649d8e2a861695126895dc96c521
+EBUILD poppassd_ceti-1.8.9.ebuild 1869 BLAKE2B 9e3ef48fac5cd0bac294714476f3b6d404e6a38bad26adf5662a0415eada52e0d2c8674077683697045021a81c4d7128133e559cb815111e8d1d11cbcd733e65 SHA512 ca02d9289a12cdeab650147fdbafdaccaa814489bc488a909230b67a5ea44a60b02fd5389e072d29ea0b95230a2038746271c02bb318e87a7c7b1368dbf88f59
MISC metadata.xml 914 BLAKE2B b6b5348eee4b5a213c13a382ae0294a25497fda65f48e8e4cacd327631357101b1509484936dc0fe0935279245b7fcc4cf15e062b333a73e281a7f793d5e016e SHA512 d1e4a0a72c157bb94ac240987b0b568b9212981f7727383eb28995f2f80e2d5f9ac0eaabbf36fd076f4237ebd84ec8e804238f92f583a63e963f1c4a20e4acf7
diff --git a/net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild b/net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild
new file mode 100644
index 000000000000..b83c13df4644
--- /dev/null
+++ b/net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake pam readme.gentoo-r1 systemd
+
+# Long ago it was just "poppassd", but upstream now seems to have
+# settled on "poppassd-ceti" (instead of "poppassd_ceti" or no suffix).
+MY_PN="poppassd-ceti"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Password change daemon with PAM support"
+HOMEPAGE="https://github.com/kravietz/poppassd-ceti"
+SRC_URI="https://github.com/kravietz/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Tests seem to hang.
+RESTRICT="test"
+
+RDEPEND="sys-libs/pam"
+DEPEND="${RDEPEND}
+ test? ( app-admin/sudo )"
+
+S="${WORKDIR}/${MY_P}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="poppassd is installed, but has to be run as root to work.
+
+Most commonly a front end would require sys-apps/xinetd and connect to
+port 106: For this, edit /etc/xinetd.d/poppassd, install sys-apps/xinetd,
+and start the xinetd service.
+
+If you use systemd, you may be able to use the installed poppassd.socket
+and poppassd.service files instead of xinetd. See README.md.bz2 and
+systemd documentation.
+
+Alternatively, a front end may be able to run it directly (if already
+root), or might use app-admin/sudo. To use sudo, you'll need to configure
+/etc/sudoers with something similar to:
+
+ apache ALL=(ALL) NOPASSWD: /usr/sbin/poppassd
+
+See also README.md.bz2 for related configuration and security
+considerations.
+"
+
+src_install() {
+ dodoc README.md
+ readme.gentoo_create_doc
+
+ pamd_mimic_system poppassd auth account password
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/poppassd.xinetd poppassd
+
+ systemd_dounit etc/systemd/poppassd.{socket,service}
+
+ exeinto /usr/sbin
+ exeopts -o root -g bin -m 500
+ doexe poppassd
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}