summaryrefslogtreecommitdiff
path: root/net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
commit7c334a9594ae315e537bf98259b95bafc60d479c (patch)
treefc41ac024e70df2bad3160b2d02fd5a01adde46b /net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild
parentd1849ceeb9c09150c11cc0d112883cfba503af27 (diff)
gentoo auto-resync : 21:07:2023 - 10:04:00
Diffstat (limited to 'net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild')
-rw-r--r--net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild b/net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild
new file mode 100644
index 000000000000..31f54d5c5608
--- /dev/null
+++ b/net-mail/pfqueue/pfqueue-0.5.6-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="pfqueue is an ncurses console-based tool for managing Postfix queued messages"
+HOMEPAGE="http://pfqueue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="sys-devel/libtool"
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+DOCS=( README ChangeLog NEWS TODO AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${PN}-0.5.6-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}