summaryrefslogtreecommitdiff
path: root/net-mail/notmuch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-mail/notmuch
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/notmuch-0.31-r1.ebuild213
2 files changed, 214 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index 196358c21bae..cf5ca6ca88e4 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -6,5 +6,6 @@ DIST notmuch-0.30.tar.xz 711904 BLAKE2B fb1523f3939b78797e448e804fc52c4fe1e4e8ff
DIST notmuch-0.31.tar.xz 713144 BLAKE2B 91b0a01543e438e6ccb40a01ad0a100a5c6ae15fe832bb29367d4bc288dae5a915f89a743ecee814041caf53430e2593cb4b5f69faaec396ad6dacfe8cc67d2f SHA512 928acc07b9dbed4275e7d39d94202bea7685e9d433a7bf4c07e40e191ed4fe8cf15ac04c18792e46f4605ffac548b942998005d8176a58ad76c82d4085a408e5
EBUILD notmuch-0.29.3-r2.ebuild 5062 BLAKE2B cdf68691f7dbc729d6c95dc974a3fb3b747a33d0b80338fc9b0474a970b78674628c242ce14af83b4d57eee1cba1f3c3d343dfcfffe2d8d0ee628f78b94f8767 SHA512 d76b455c44244eb1775604b0510f96c30aea175492ea4982d9a5b93d8601834a120286f29b8e41c6e694209a09be72727848e24bf5b8b3723729c2458095cc08
EBUILD notmuch-0.30-r1.ebuild 4343 BLAKE2B f53eff50b205bffdb6016118997a5b5176a88ca704999e2b4f3bef4f107a79e7e89e68010fc35bd756aa8cbbe168f73700eba9b33ec8f1ce32a676b1b592e5da SHA512 bde0d770ca18d3c55c79be0b4e6fb360f61bf0f404397448fb311c1cf107b07b5f9633643a04a0e6615acd61934635845d1a2a47283795e3fd69c050939858b1
+EBUILD notmuch-0.31-r1.ebuild 4444 BLAKE2B 3bfc5bf340d8af0f4e351394d41d38de8b73cf959fee108de8ec53690e9b42ecedf0125f90ae2413384d65197f926beac1ced7a8120d2da48e20b85ef1289be0 SHA512 53854173c8b326d9d7e1c7ad826f2f77b61fc605bab54fa9084e41025a91ea14a671bfeaf036ba861b71ceeb83bc0661cd610600e4e9a971c9265ac7d6008c2f
EBUILD notmuch-0.31.ebuild 4460 BLAKE2B 21bea26e7e287937cd45a553abb14cb40420b2bb93886165533f6808d4734e594bd0184fb4b8dd6230b2264dc09f80dd89eeea70f678e7a56981e11f743c1121 SHA512 e12a5c8403c7f7e0ce32a1f002a4e6153b01df9436a517f692b18860a919aac83787a59ae6a00820b2d6fae7661a14a4f822d16b79c2e037f539afddfba04f62
MISC metadata.xml 1229 BLAKE2B 7a7bc05dd0bd1fbfca066e1041d56068c3e8dfd45359be606d0e7703876c831f0b0a39b0dcea4b44f3ec034a16c906bb1ad703143e244c95487d94d9bf9331b4 SHA512 d100677a61010239386889afd5c0f3444c77f5b42309738668c89409bec8f81f2856eb2e5d00d9d495b94a4111df7209f4cc84b830ef346e57c686e5ccbea24e
diff --git a/net-mail/notmuch/notmuch-0.31-r1.ebuild b/net-mail/notmuch/notmuch-0.31-r1.ebuild
new file mode 100644
index 000000000000..f5fd2cc5cf82
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.31-r1.ebuild
@@ -0,0 +1,213 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+NEED_EMACS="24.1"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit bash-completion-r1 distutils-r1 elisp-common eutils flag-o-matic \
+ pax-utils toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="https://notmuchmail.org/releases/${P}.tar.xz
+ test? ( https://notmuchmail.org/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc64 ~x86"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+"
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+"
+COMMON_DEPEND="
+ dev-libs/glib
+ dev-libs/gmime:3.0[crypt]
+ >=dev-libs/xapian-1.4.0:=
+ sys-libs/talloc
+ sys-libs/zlib
+ emacs? ( >=app-editors/emacs-${NEED_EMACS}:* )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/cffi
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ test? (
+ >=app-editors/emacs-${NEED_EMACS}:*[libxml2]
+ app-misc/dtach
+ sys-devel/gdb
+ crypt? (
+ app-crypt/gnupg
+ dev-libs/openssl
+ )
+ )
+ valgrind? ( dev-util/valgrind )
+"
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/gnupg )
+ mutt? (
+ dev-perl/File-Which
+ dev-perl/Mail-Box
+ dev-perl/MailTools
+ dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ )
+ nmbug? ( dev-vcs/git )
+"
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+
+bindings() {
+ local rc=0
+ if use python; then
+ # CFFI based bindings (recommended)
+ pushd bindings/python-cffi || die
+ ${@}
+ rc=${?}
+ popd || die
+
+ # Old deprecated bindings, #736204. These are known to cause
+ # memory loss and other issues. Avoid if at all possible.
+ pushd bindings/python || die
+ ${@}
+ rc=${?}
+ popd || die
+ fi
+ return ${rc}
+}
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_unpack() {
+ unpack "${P}".tar.xz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ local _deps=""
+ default
+
+ # Python bindings
+ bindings distutils-r1_src_prepare
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # Override dependencies for 'install' target
+ use doc && _deps="install-info"
+ sed -e "s/^install:.\+/install: all ${_deps}/" -i Makefile.local || die
+
+ if use test; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # Non-autoconf configure
+ append-ldflags -lnsl -lsocket
+ fi
+}
+
+src_configure() {
+ python_setup # For sphinx
+ local _args=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ $(use_with doc api-docs)
+ )
+ tc-export CC CXX
+ econf "${_args[@]}"
+}
+
+src_compile() {
+ python_setup # For sphinx
+ V=1 default
+ bindings distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${WORKDIR}/${P}/lib" V=1 default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+ doman doc/_build/man/man?/*.?
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings distutils-r1_src_install
+}
+
+pkg_preinst() {
+ local _rcfile="/etc/mutt/notmuch-mutt.rc"
+ if use mutt && ! [[ -e ${ROOT}${_rcfile} ]]; then
+ elog "To enable notmuch support in mutt, add the following line"
+ elog "to your mutt config file:"
+ elog ""
+ elog " source ${_rcfile}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}