summaryrefslogtreecommitdiff
path: root/net-mail/mpop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-01 01:33:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-01 01:33:27 +0100
commit9cb5d77a6732fadf391fd38da00e6921f3e23112 (patch)
tree30f5c59801151fa131da4743ca598f950b2e5b4b /net-mail/mpop
parent033286afc1eb2e64a87a58798a0c620d8b56f497 (diff)
gentoo auto-resync : 01:04:2025 - 01:33:27
Diffstat (limited to 'net-mail/mpop')
-rw-r--r--net-mail/mpop/Manifest4
-rw-r--r--net-mail/mpop/mpop-1.4.21.ebuild53
-rw-r--r--net-mail/mpop/mpop-1.4.7-r1.ebuild (renamed from net-mail/mpop/mpop-1.4.7.ebuild)15
3 files changed, 65 insertions, 7 deletions
diff --git a/net-mail/mpop/Manifest b/net-mail/mpop/Manifest
index 868153449e50..0db9aeef3ed9 100644
--- a/net-mail/mpop/Manifest
+++ b/net-mail/mpop/Manifest
@@ -1,3 +1,5 @@
+DIST mpop-1.4.21.tar.xz 405468 BLAKE2B 9bc96542515413d1a0db6c101d07e4fd2a347fb53f3bb5757a0942fec6f158678470df9744fc76e883fce4a766b46ae3a0f0f0514c5537fc36fc80b37784a288 SHA512 bdf4fe3b44b2d6c6ef95324db7e3b1b09a559405fe3faa20e1d61cd728c255f1f56f0329a6ac789da34d6c819002edaba51f148afe72afe48507718aca1fb70a
DIST mpop-1.4.7.tar.xz 322488 BLAKE2B ea73e84b5ed3b5aad7ef91ceb510187c3f2d42976329a6a53511329a84713edc056ca6db35b1de2c9bff8b417e2710e598c472e78acbdc499dd73b24c46dfb47 SHA512 ce0ac899fd2af1d50ef221c88282c12263c5862b9ff1f6341a8551c3fe6b69272772599a2040a0f553a776245514c55b8102ca8cf291b411e5127a3f39897832
-EBUILD mpop-1.4.7.ebuild 1051 BLAKE2B 14c623d39116e9250f276bd75b82fdb6a4a0c8a521056ae74a9110798a0fc6893903e8e89f298deda65373446b761e5e6e2307243226d37b0e6bd999ea5fb6ef SHA512 0fe5beb5146ff5d6bd6017d2de598af8406130d4746eecd1262d863af9a09085676313df05352405bd1f134222a9da92d2e093e92cb1ddaa6d631d91c946a1dc
+EBUILD mpop-1.4.21.ebuild 1076 BLAKE2B ec16bbd5457bd23b28e442b3c22fe74f3994dde62118c65818b80f1f45acb6ad9a361acc0a812e32d3ca5e6bc03e4806880dffd49e425c83ddb4a1f25a993b48 SHA512 24878459ad79ea39315d2c1f1718ab4d88d6cec6f0a6a9b15937f91d2824bf8352c4b3b225d3fbe51dc083671ae21565e04f2947a1580b4c3786fb1ddc8206dc
+EBUILD mpop-1.4.7-r1.ebuild 1063 BLAKE2B a2b3052ae9122e4ad328f76b3dd29728d9b3612713ceed609befc2d6974f977ad29bdddfd3a5f0b12af9ef7f3e1d6f7d76241c5ee356209d13f687df10e7653c SHA512 933cb06eec04628335bae3c158eedf0999dce324898436c6c172d956e66f5b9b9c248e03553e2b057cce4516140abdb9700403281c048af80572f0133816ba6d
MISC metadata.xml 242 BLAKE2B ccfd1df5ba047ee31ff30c7522c928785f42d24ae1f33bd764477edd41f0f6543b66f5d442cc8306a100a99daa5d4cae59b92670fbb6b4e3b198a1db18995524 SHA512 b3589c59c2827a4944ad49cabb7547832af96bc529cc9e1e44c79887d2bddeb1ec978f3068b98c0dd8c6a3f3bd5bc332583ecc0ae57f0597b30c726e2cd5fa83
diff --git a/net-mail/mpop/mpop-1.4.21.ebuild b/net-mail/mpop/mpop-1.4.21.ebuild
new file mode 100644
index 000000000000..05f2840f21f4
--- /dev/null
+++ b/net-mail/mpop/mpop-1.4.21.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Small, fast, and portable POP3 client"
+HOMEPAGE="https://marlam.de/mpop/"
+SRC_URI="https://marlam.de/mpop/releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gnutls idn keyring nls sasl ssl"
+REQUIRED_USE="gnutls? ( ssl )"
+
+RDEPEND="
+ idn? ( net-dns/libidn2 )
+ keyring? ( app-crypt/libsecret )
+ nls? ( virtual/libintl )
+ sasl? ( >=net-misc/gsasl-2.1[client] )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:=[idn?] )
+ !gnutls? (
+ dev-libs/openssl:=
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NOTES README THANKS )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_with ssl tls $(usex gnutls "gnutls" "openssl"))
+ $(use_with sasl libgsasl)
+ $(use_with idn libidn)
+ $(use_with keyring libsecret)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/mpop.vim
+}
diff --git a/net-mail/mpop/mpop-1.4.7.ebuild b/net-mail/mpop/mpop-1.4.7-r1.ebuild
index 7e12850dd83b..ed615a5183b0 100644
--- a/net-mail/mpop/mpop-1.4.7.ebuild
+++ b/net-mail/mpop/mpop-1.4.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,16 +16,19 @@ RDEPEND="
idn? ( net-dns/libidn2 )
keyring? ( app-crypt/libsecret )
nls? ( virtual/libintl )
- sasl? ( virtual/gsasl )
+ sasl? ( net-misc/gsasl[client] )
ssl? (
gnutls? ( net-libs/gnutls:0=[idn?] )
!gnutls? (
- dev-libs/openssl:0=
+ dev-libs/openssl:=
)
- )"
-DEPEND="${RDEPEND}
+ )
+"
+DEPEND="
+ ${RDEPEND}
nls? ( sys-devel/gettext )
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
REQUIRED_USE="gnutls? ( ssl )"