summaryrefslogtreecommitdiff
path: root/net-mail/mpack/mpack-1.6-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/mpack/mpack-1.6-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/mpack/mpack-1.6-r4.ebuild')
-rw-r--r--net-mail/mpack/mpack-1.6-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/mpack/mpack-1.6-r4.ebuild b/net-mail/mpack/mpack-1.6-r4.ebuild
new file mode 100644
index 000000000000..549f2af53198
--- /dev/null
+++ b/net-mail/mpack/mpack-1.6-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+AT_M4DIR=cmulocal
+
+inherit autotools
+
+DESCRIPTION="Command-line MIME encoding and decoding utilities"
+HOMEPAGE="ftp://ftp.andrew.cmu.edu/pub/mpack/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/mpack/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="HPND"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-filenames.patch
+ "${FILESDIR}"/${P}-usage.patch
+ "${FILESDIR}"/${P}-munpack.patch
+ # NOTE: These three patches replace <mpack-1.6-gentoo.patch>
+ "${FILESDIR}"/${P}-compile.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-cve-2011-4919.patch
+
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc README.* Changes
+}