summaryrefslogtreecommitdiff
path: root/net-mail/mboxgrep/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/mboxgrep/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/mboxgrep/files')
-rw-r--r--net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch b/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch
new file mode 100644
index 000000000000..dd0742626b47
--- /dev/null
+++ b/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch
@@ -0,0 +1,52 @@
+commit f51a9eafb80a5c5e506d7fe416c0b768ec1a6655
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 20:11:32 2011 +0300
+
+ Respect LDFLAGS and do not strip
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index fc5ac74..2b89866 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -39,7 +39,7 @@ INCLUDES = -I. -I$(srcdir)
+ $(CC) $(CFLAGS) $(INCLUDES) -c $<
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ .PHONY: clean
+ clean:
+@@ -52,6 +52,6 @@ distclean:
+ .PHONY: install
+ install: mboxgrep
+ $(INSTALL) -d $(prefix)/bin
+- $(INSTALL) -s $(TARGET) $(prefix)/bin
++ $(INSTALL) $(TARGET) $(prefix)/bin
+
+ .NOEXPORT:
+commit 1a0a345ad4c38df41227e3f2600bcf05ed49bbd7
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 20:52:06 2011 +0300
+
+ everyone has standard C headers nowadays
+
+diff --git a/src/md5.c b/src/md5.c
+index d6b8013..a797552 100644
+--- a/src/md5.c
++++ b/src/md5.c
+@@ -26,14 +26,8 @@
+
+ #include <sys/types.h>
+
+-#if STDC_HEADERS || defined _LIBC
+ # include <stdlib.h>
+ # include <string.h>
+-#else
+-# ifndef HAVE_MEMCPY
+-# define memcpy(d, s, n) bcopy ((s), (d), (n))
+-# endif
+-#endif
+
+ #include "md5.h"
+