summaryrefslogtreecommitdiff
path: root/net-mail/mailbox-count
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-mail/mailbox-count
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-mail/mailbox-count')
-rw-r--r--net-mail/mailbox-count/Manifest2
-rw-r--r--net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch24
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild40
3 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/mailbox-count/Manifest b/net-mail/mailbox-count/Manifest
index 4e0da5e59530..5aeb89853e75 100644
--- a/net-mail/mailbox-count/Manifest
+++ b/net-mail/mailbox-count/Manifest
@@ -1,3 +1,5 @@
+AUX mailbox-count-0.0.2-ghc84.patch 905 BLAKE2B d786519b6c9bcebd0c2d5719e469b2d3be2553b46ae58878ba47b7720111355b64c31e67f95a84b99dd482e7c88b81426eb35da3938937a030e31e5577cdc290 SHA512 046b2a6a185ee43823bc1b4906d3b3f79a4785e61b2c8c856cf0426dfc3de7dc59be9ab981f5b0a76c2eb4528c6f15a5c4672cb266de69bc299cf0aa4e6e8bb2
DIST mailbox-count-0.0.2.tar.gz 20644 BLAKE2B 036d118f9c23d42e21de06405d2703e97017f35d618a90e77561d604441092b543a8ba03b50dee5a7c2a48c2b8c0d6e87c06c2338853d9c508de7b6ea9d86006 SHA512 98e39927382719295260c64bd5888244000dbbb3fbd7f6405dcffe78a4fc5f1dea7f8236542e58eb0118bb421c19225a8be0560b92c7688c0701418c7221d569
EBUILD mailbox-count-0.0.2-r1.ebuild 821 BLAKE2B b9a4977bb2af16c294a8559ab466a568cae6e60192e9a3cbc7e69e590baa0f896d87b52a8e756f17ac47b0fa3b9756a64252a3a0f6cc18f4f0bda55b8c4a630c SHA512 3c6a241379adcc4d4892b6c44cc4bf889816fcaf9d48e9cbc96987f2e729eae734ef1020cb69d67d8042443638370cea44889bd20231f359c7ecd1f5b361ef74
+EBUILD mailbox-count-0.0.2-r2.ebuild 931 BLAKE2B c8d77610209bc30e992e1daa1eac40870c86de575f4fb116fb1a6d77015395fa6f3dec228018c20ce2055dfa97e5c9a78f0fd95fe5bd3fb2bc057df6e996a186 SHA512 207abfda7a3f50a7ee18b44461887bcb5b7680bc29d5fea864d564293ae271158b93261e22e1ebbfd990ed3df0102d7cacdb0861338c92c48e0ffd6ada2fe7b0
MISC metadata.xml 3288 BLAKE2B 15a60ecab50dad246513c9060e9cf73b4a00c4a6264085357c04461e83a262497780c831823fd54a94d2c2a2b10cd836c51632e24683bbc5d0541d657e383a4e SHA512 95bbd72ec2a640fc2f4d9b67ce8388edbf3b7e01e181bc874fd62d11fabc5858506c35e613bb9215e6732ae4c968ad87df3b93b917cded023691452d0368e8d9
diff --git a/net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch b/net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch
new file mode 100644
index 000000000000..5257a10a3ac3
--- /dev/null
+++ b/net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch
@@ -0,0 +1,24 @@
+--- a/src/OptionalConfiguration.hs
++++ b/src/OptionalConfiguration.hs
+@@ -27,3 +27,3 @@ import System.FilePath ( (</>) )
+ import System.IO.Error ( catchIOError )
+-
++import qualified Data.Semigroup as S
+
+@@ -65,2 +65,16 @@ merge_maybes (Just _) (Just y) = Just y
+ --
++
++instance S.Semigroup OptionalConfiguration where
++ -- | Combine @cfg1@ and @cfg2@, giving precedence to @cfg2@.
++ cfg1 <> cfg2 =
++ OptionalConfiguration
++ (merge_maybes (database cfg1) (database cfg2))
++ (merge_maybes (detail cfg1) (detail cfg2))
++ (merge_maybes (detail_query cfg1) (detail_query cfg2))
++ (merge_maybes (host cfg1) (host cfg2))
++ (merge_maybes (password cfg1) (password cfg2))
++ (merge_maybes (port cfg1) (port cfg2))
++ (merge_maybes (summary_query cfg1) (summary_query cfg2))
++ (merge_maybes (username cfg1) (username cfg2))
++
+ instance Monoid OptionalConfiguration where
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild
new file mode 100644
index 000000000000..275709ed0d99
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.2
+
+CABAL_FEATURES="bin test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="http://hackage.haskell.org/package/mailbox-count"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # Could not find module ‘Paths_mailbox_count’
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-lang/ghc-7.6.1
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ghc84.patch
+)